The Icacls.exe utility cannot display non-English languages on Windows Server 2003 Service Pack 2-based computers

Support for Windows Server 2003 ended on July 14, 2015

Microsoft ended support for Windows Server 2003 on July 14, 2015. This change has affected your software updates and security options. Learn what this means for you and how to stay protected.

This article has been archived. It is offered "as is" and will no longer be updated.
SYMPTOMS
The Icacls.exe utility cannot display non-English languages, such as Japanese or Chinese, on Windows Server 2003 Service Pack 2-based computers.

For example, assume that you use the Icacls.exe utility to display the security settings of a folder, and this folder contains files that have Japanese or Chinese file names. In this case, the Icacls.exe utility cannot display these Japanese or Chinese file names.
CAUSE
The Icacls.exe utility does not correctly handle non-English characters.
RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, your computer must be running one of the following operating systems:
  • A 32-bit version of Windows Server 2003 with Service Pack 2 (SP2)
  • An Itanium-based version of Windows Server 2003 with SP2
  • An x64-based version of Windows Server 2003 with SP2
  • An x64-based version of Windows XP with SP2

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

Registry information

To use this hotfix, you do not have to make any changes to the registry.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with SP2, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Icacls.exe5.2.3790.423540,96013-Feb-200809:40x86
Windows Server 2003 with SP2, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Icacls.exe5.2.3790.423585,50414-Feb-200807:43IA-64SP2Not Applicable
Wicacls.exe5.2.3790.423540,96014-Feb-200807:43x86SP2WOW
Windows Server 2003 with SP2 and Windows XP with SP2, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Icacls.exe5.2.3790.423556,83214-Feb-200807:46x64SP2Not Applicable
Wicacls.exe5.2.3790.423540,96014-Feb-200807:46x86SP2WOW
STATUS
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
MORE INFORMATION
The Icacls.exe utility was introduced in Windows Server 2003 SP2. You can use this utility to modify NTFS file system permissions on a computer that is running Windows Server 2003 with SP2.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
919240 The Icacls.exe utility is available for Windows Server 2003 with Service Pack 2

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Technical support for x64-based versions of Microsoft Windows

If your hardware came with a Microsoft Windows x64 edition already installed, your hardware manufacturer provides technical support and assistance for the Windows x64 edition. In this case, your hardware manufacturer provides support because a Windows x64 edition was included with your hardware. Your hardware manufacturer might have customized the Windows x64 edition installation by using unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you must have technical help with a Windows x64 edition. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware. If you purchased a Windows x64 edition such as a Windows Server 2003 x64 edition separately, contact Microsoft for technical support.

For product information about Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about x64-based versions of Windows Server 2003, visit the following Microsoft Web site:
Properties

Article ID: 944820 - Last Review: 01/16/2015 02:36:20 - Revision: 2.0

  • Microsoft Windows Server 2003 Service Pack 2
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