Lookup attributes are inactive on the activity form after you upgrade from Microsoft Dynamics CRM 3.0 to Microsoft Dynamics CRM 4.0

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Symptoms
After you upgrade from Microsoft Dynamics CRM 3.0 to Microsoft Dynamics CRM 4.0, lookup attributes are inactive on the activity form. For example, the To lookup attribute and the From lookup attribute on the E-mail form are inactive.
Cause
The lookup attribute was customized in Microsoft Dynamics CRM 3.0. The customization updated the field XML to contain additional field parameters. The additional field parameters are incorrectly duplicated during the upgrade to Microsoft Dynamics CRM 4.0. These duplicate values cause the metadata lookup to display the lookup attribute as inactive.
Resolution
This problem is fixed in the latest cumulative update rollup for Microsoft Dynamics CRM 4.0. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
949256 Microsoft Dynamics CRM 4.0 updates and hotfixes
More information
To verify that you are experiencing the problem in the "Symptoms" section, follow these steps:
  1. Locate the Attribute GUID value and the Entity GUID value. To do this, start Microsoft Dynamics CRM 4.0, click Settings, click Customization, and then click Customize Entities.
  2. Double-click the entity that contains the inactive attribute.
  3. Double-click Attributes.
  4. Double-click the attribute that is inactive.
  5. Press F11 to receive the QueryString URL address. The URL address will resemble the following:
    http://<crmurl>/<organization>/Tools/SystemCustomization/Attributes/manageAttribute.aspx?attributeId={DC576E7F-8A5C-4AB0-90D9-573773931AAA}&entityId={95ae88b3-cc0c-45ac-a2db-655dceec238b}
  6. Copy the AttributeID GUID value and the EntityID GUID value to Notepad.
  7. Start Microsoft SQL Server Management Studio, expand Databases, and then click the Microsoft Dynamics CRM Organization_MSCRM database.
  8. Click New Query.
  9. Copy the following SQL statement.

    Note You must replace the GUID values in the SQL statement with the GUID values in step 5.
    Select * from attributeLookupValue where attributeId in(Select attributeID from attribute where attributeId='DC576E7F-8A5C-4AB0-90D9-573773931AAA'and entityid = '95ae88b3-cc0c-45ac-a2db-655dceec238b')
  10. Click Execute.

    The results should display unique EntityIds values for each AttributeLookupValueId value. Duplicate EntityIds values in this table will cause the lookup attributes to appear inactive.
Properties

Article ID: 947982 - Last Review: 01/17/2015 05:27:00 - Revision: 4.0

  • Microsoft Dynamics CRM 4.0
  • kbnosurvey kbarchive kbhotfixserver kbqfe kbmbsmigrate KB947982
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