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Problems occur in Windows Server 2008 after you uninstall a SQL Server 2005 failover cluster, or after you install SQL Server 2005 Service Pack 2 or a Service Pack 2-based hotfix on a SQL Server 2005 failover cluster

Extended support for SQL Server 2005 ends on April 12, 2016

If you are still running SQL Server 2005 after April 12, 2016, you will no longer receive security updates and technical support. We recommend upgrading to SQL Server 2014 and Azure SQL Database to achieve breakthrough performance, maintain security and compliance, and optimize your data platform infrastructure. Learn more about the options for upgrading from SQL Server 2005 to a supported version here.

SYMPTOMS
You experience the following problems on a server that is running Windows Server 2008.

Problem 1

You uninstall a Microsoft SQL Server 2005 failover cluster. However, the group that contains the shared disk still appears in Failover Cluster Management. If you install a new SQL Server 2005 failover cluster, the group appears on the Cluster Group Selection page. See Workaround 1.

Problem 2

You install SQL Server 2005 Service Pack 2 (SP2) or a SQL Server 2005 SP2-based hotfix on the primary node of a SQL Server 2005 failover cluster. The Setup program of SQL Server 2005 SP2 or of the hotfix reports that the installation is successful. However, SQL Server 2005 SP2 or the SQL Server 2005 SP2-based hotfix is not installed on the remote nodes.

This problem occurs if the remote nodes do not have sufficient space on drive C. See Workaround 2.
CAUSE

Cause 2

Problem 2 occurs because the Msiexec.exe tool returns the exit code 0 if the tool cannot extract the package for SQL Server 2005 SP2. The exit code 0 notifies the Setup program of SQL Server 2005 SP2 or of the SQL Server 2005 SP2-based hotfix that SQL Server 2005 SP2 or the SQL Server 2005 SP2-based hotfix is successfully installed on the remote nodes.
WORKAROUND

Workaround 1

To work around this problem, manually delete the group that contains the shared disk in Failover Cluster Management. To do this, follow these steps:
  1. Click Start, point to Administrative Tools, and then click Failover Cluster Management.
  2. In Failover Cluster Management, expand the cluster that contains the group, expand Services and Applications, right-click the group, and then click Delete.

Workaround 2

To work around this problem, make sure that drive C on the remote nodes has at least 400 MB of free space before you install SQL Server 2005 SP2 or the SQL Server 2005 SP2-based hotfix.
STATUS
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
Properties

Article ID: 948210 - Last Review: 09/11/2010 10:11:00 - Revision: 1.2

Microsoft SQL Server 2005 Standard Edition, Microsoft SQL Server 2005 Developer Edition, Microsoft SQL Server 2005 Enterprise Edition, Windows Server 2008 Standard, Windows Server 2008 Enterprise, Windows Server 2008 Datacenter

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