You receive error messages after you uninstall SQL Native Client from a server that is running SQL Server 2005

Extended support for SQL Server 2005 ended on April 12, 2016

If you are still running SQL Server 2005, you will no longer receive security updates and technical support. We recommend upgrading to SQL Server 2014 and Azure SQL Database to achieve breakthrough performance, maintain security and compliance, and optimize your data platform infrastructure. Learn more about the options for upgrading from SQL Server 2005 to a supported version here.

SYMPTOMS
After you uninstall SQL Native Client from a server that is running Microsoft SQL Server 2005, the following behavior occurs:
  • When you try to start the SQL Server Agent service, you receive the following error message:
    The request failed or the service did not respond in a timely fashion. Consult the event log or other applicable error logs for details.
    Additionally, the following events are logged in the System log:
    Event 1

    Event Type: Error
    Event Source: Service Control Manager
    Event Category: None
    Event ID: 7009
    Description: Timeout (30000 milliseconds) waiting for the SQL Server Agent (InstanceName) service to connect.

    Event 2

    Event Type: Error
    Event Source: Service Control Manager
    Event Category: None
    Event ID: 7000
    Description: The SQL Server Agent (InstanceName) service failed to start due to the following error:
    The service did not respond to the start or control request in a timely fashion.

  • When you try to use the bcp command prompt utility, you receive the following error message:
    This application has failed to start because sqlncli.dll was not found. Re-installing the application may fix this problem.
CAUSE
This behavior occurs because the SQL Server Agent service and the bcp command prompt utility use the Open Database Connectivity (ODBC) Bulk Copy Program (BCP) API. The ODBC BCP API must link with SQL Native Client. If SQL Native Client does not exist, the SQL Server Agent service cannot be loaded. Additionally, the bcp command prompt utility cannot start.
WORKAROUND
To work around this behavior, install SQL Native Client. To do this, use one of the following methods, depending on the version of SQL Server 2005 that the server is running.

Method 1: The release version of SQL Server 2005

If the server is running the release version of SQL Server 2005, follow these steps:
  1. Obtain the SQL Server 2005 installation media.
  2. In the following location, double-click the Sqlncli.msi file:
    InstallationMedia\Tools\Setup

Method 2: SQL Server 2005 Service Pack 1 or SQL Server 2005 Service Pack 2

If the server is running SQL Server 2005 Service Pack 1 or SQL Server 2005 Service Pack 2, follow these steps:
  1. Extract the package of SQL Server 2005 Service Pack 1 or of SQL Server 2005 Service Pack 2.
  2. In the following location, double-click the Sqlncli.msi file:
    ExtractedPath\hotfixsqlncli\files
STATUS
This behavior is by design.
MORE INFORMATION
For more information about how to obtain SQL Server 2005 Service Pack 1 or SQL Server 2005 Service Pack 2, click the following article number to view the article in the Microsoft Knowledge Base:
913089 How to obtain the latest service pack for SQL Server 2005
Properties

Article ID: 948907 - Last Review: 02/28/2008 21:36:15 - Revision: 1.2

Microsoft SQL Server 2005 Standard Edition, Microsoft SQL Server 2005 Workgroup Edition, Microsoft SQL Server 2005 Developer Edition, Microsoft SQL Server 2005 Enterprise Edition

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