No search results are returned after you detach and then reattach a content database in SharePoint Server 2007 or in Windows SharePoint Services 3.0

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SYMPTOMS
In Microsoft Office SharePoint Server 2007 or in Microsoft Windows SharePoint Services 3.0, you detach a content database and then reattach it to the same Web application or to another Web application. After you do this, no search results are returned when you perform a search.
CAUSE
This issue may occur when the full crawl that is required after you reattach the database is not yet finished. Windows SharePoint Services 3.0 and SharePoint Server 2007 require a full crawl after you reattach the database because the change log is removed during this process.

Note The full crawl can take some time before it shows complete results that include new content.
WORKAROUND
To work around this issue, start a full crawl. To do this, follow these steps.

Windows SharePoint Services 3.0

  1. On the server, open a command prompt, and then change directory to the following directory:
    C:\Program Files\Common Files\Microsoft Shared\web server extensions\12\BIN
  2. Type stsadm -o spsearch -action fullcrawlstart, and then press ENTER.

SharePoint Server 2007

  1. On the server, click Start, point to Administrative Tools, and then click SharePoint 3.0 Central Administration.
  2. On the Central Administration site, click SharedServices1 in the Quick Launch bar under the Shared Services Administration heading.
  3. Under the Search header, click Search Settings.
  4. Click Content Sources and Crawl Schedules.
  5. On the Manage Content Sources page, pause the pointer over each content source, and then click the list for the item. On the list, click Start Full Crawl.
Properties

Article ID: 949603 - Last Review: 01/15/2015 09:04:50 - Revision: 1.0

  • Microsoft Office SharePoint Server 2007
  • Microsoft Windows SharePoint Services 3.0
  • kbnosurvey kbarchive kbtshoot kbexpertiseadvanced kbnofix kbprb KB949603
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