Returning to the Last Editing Position When Opening Files

This article was previously published under Q95694
This article has been archived. It is offered "as is" and will no longer be updated.
SYMPTOMS
Microsoft Word does not retain the location of your insertion point whenyou save and close a document.
CAUSE
This occurs by product design.
WORKAROUND

Word 7.0, 97

Press SHIFT+F5 after you open the document to move the cursor to itsprevious location.

Word 2.0, 6.0

The following AutoOpen macro can be used to return your insertionpoint to its last editing position when a document is opened:
   Sub MAIN   If ExistingBookmark("\PrevSel1") Then EditGoTo "\PrevSel1"   End Sub				
To create the above macro:

  1. From the Tools menu, choose Macro.
  2. From the Show box, select the Global Macro option.
  3. Type AutoOpen for the macro name and choose the Edit button.
  4. Type the following macro line between the Sub MAIN and End Sub lines:
    If ExistingBookmark("\PrevSel1") Then EditGoTo "\PrevSel1"					
  5. From the File menu, choose Close. Choose the Yes button when prompted to save changes to Global:AutoOpen.
  6. From the File menu, choose Save All. When prompted, choose to save global glossary and command changes.
MORE INFORMATION
If you want to return to a specific location each time you open adocument, insert a bookmark at that location and then record anAutoNew macro that goes to that bookmark.
REFERENCES
"Using WordBasic," by WexTech Systems and Microsoft, pages 88-89 andpage 184.
winword2 2.0 6.0.1 word7 word6 winword 7.0 word95 autoopen auto open 6.0 macword 6.0.1a word97
Properties

Article ID: 95694 - Last Review: 10/21/2013 16:48:22 - Revision: 2.3

  • Microsoft Word 2.0 Standard Edition
  • Microsoft Word 2.0a
  • Microsoft Word for Windows 2.0b
  • Microsoft Word 2.0c
  • Microsoft Word 6.0 Standard Edition
  • Microsoft Word 6.0a
  • Microsoft Word 6.0c
  • Microsoft Word 95 Standard Edition
  • Microsoft Word 95a
  • Microsoft Word 97 Standard Edition
  • Microsoft Word 6.0 for Macintosh
  • Microsoft Word 6.01 for Macintosh
  • Microsoft Word 6.01 for Macintosh
  • kbnosurvey kbarchive KB95694
Feedback