The system stops responding, and the logoff process stops at an "End Program: Tabtip.exe" message when you try to shut down, restart, or log off from a computer or the WISPTIS.EXE process crashes

Support for Windows XP has ended

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SYMPTOMS
When you try to shut down, restart, or log off from a computer that is running Windows XP Tablet PC Edition 2005 the system stops responding. Additionally, the logoff process stops at the following message: 
End Program: Tabtip.exe.
Ending Program: Please Wait.

Or
When you plug in a digitizer device to a Windows XP Professional Service Pack 3 the wisptis.exe process crashes when you plug in a digitizer device.
CAUSE
This problem occurs because the Tabtip.exe program does not unload successfully. This occurs because a deadlock occurs during the logoff process.
RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows XP Service Pack 2 or Windows XP Service Pack 3 installed.
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
322389 How to obtain the latest Windows XP service pack

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows XP Tablet Edition 2005 with Service Pack 2, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Wisptis.exe1.7.2600.3436293,88828-Aug-200810:32x86
Windows XP Tablet Edition 2005 with Service Pack 3, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Wisptis.exe1.7.2600.5665293,88828-Aug-200811:04x86
Windows XP Professional with Service Pack 3, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Wisptis.exe1.7.2600.5687293,88828-Aug-200811:04x86
STATUS
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
MORE INFORMATION
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
hang upon shutdown crash
Properties

Article ID: 957282 - Last Review: 10/08/2011 03:54:00 - Revision: 4.0

Microsoft Windows XP Tablet PC Edition 2005, Microsoft Windows XP Tablet PC Edition, Microsoft Windows XP Professional

  • kbwinxppostsp3fix kbautohotfix kbexpertisebeginner kbbug kbfix kbqfe KB957282
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