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All the PCL inbox printer drivers become unsigned after you install the Microsoft .NET Framework 3.5 Service Pack 1

Support for Windows XP has ended

Microsoft ended support for Windows XP on April 8, 2014. This change has affected your software updates and security options. Learn what this means for you and how to stay protected.

Support for Windows Server 2003 ended on July 14, 2015

Microsoft ended support for Windows Server 2003 on July 14, 2015. This change has affected your software updates and security options. Learn what this means for you and how to stay protected.

SYMPTOMS
On a Windows XP-based or Windows Server 2003-based computer, after you install the Microsoft .NET Framework 3.5 Service Pack 1, all the Printer Control Language (PCL) inbox printer drivers become unsigned.

Note The .NET Framework 3.5 SP1 includes the Microsoft XML Paper Specification Essentials Pack that contains an updated Unidrv.dll file.

This problem causes several issues. For example, Windows Management Instrumentation (WMI) may be unable to install a printer driver.
CAUSE
This issue occurs because the Unidrv.dll file is unsigned. Therefore, all PCL inbox printer drivers become unsigned after the installation of this file.
RESOLUTION
An update is available to resolve this problem. This update releases a digital signature for the Unidrv.dll file.

The following files are available for download from the MicrosoftDownload Center:


Update for Windows XP, x86-based versions

DownloadDownload the 961118 package now.

Update for Windows XP, x64-based versions

DownloadDownload the 961118 package now.

Update for Windows Server 2003, x86-based versions

DownloadDownload the 961118 package now.

Update for Windows Server 2003, x64-based versions

DownloadDownload the 961118 package now.

Release Date: February 8, 2009

For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591 How to obtain Microsoft support files from online services
Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.

Prerequisites

To apply this update, the computer must run one of the following operating systems:
  • Windows XP Service Pack 2
  • Windows XP Service Pack 3
  • Windows Server 2003 Service Pack 1
  • Windows Server 2003 Service Pack 2

Restart requirement

You have to restart the computer after you apply this update.

Hotfix replacement information

This update does not replace any other previously released hotfixes.

File information

The English version of this update has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows XP, x86-based version

File nameFile versionFile sizeDateTimeSP requirementService branch
Ntprint.catNot Applicable1,089,60109-Jan-200919:18SP2SP2QFE
Ntprint.catNot Applicable1,089,59309-Jan-200919:19SP3SP3QFE

Windows Server 2003, x86-based version

File nameFile versionFile sizeDateTimeSP requirementService branch
Ntprint.catNot Applicable1,107,11509-Jan-200920:47SP1SP1QFE
Ntprint.catNot Applicable1,107,11509-Jan-200920:51SP2SP2QFE

Windows Server 2003 and Windows XP, x64-based version

File nameFile versionFile sizeDateTimeSP requirementService branch
Ntprint.catNot Applicable1,106,22109-Jan-200918:15SP1SP1QFE
Ntprint.catNot Applicable1,110,38509-Jan-200918:25SP2SP2QFE
STATUS
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
MORE INFORMATION
Drivers that are included with an operating system or service pack release are known as inbox drivers. Inbox drivers are drivers that are released with catalog files. Drivers that are trusted by the catalog are known as signed drivers. Drivers that are released without the catalog file are known as unsigned drivers.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
Properties

Article ID: 961118 - Last Review: 10/08/2011 00:21:00 - Revision: 2.0

Microsoft Windows Server 2003, Datacenter Edition (32-bit x86), Microsoft Windows Server 2003, Datacenter x64 Edition, Microsoft Windows Server 2003, Enterprise x64 Edition, Microsoft Windows Server 2003, Enterprise Edition (32-bit x86), Microsoft Windows Server 2003, Standard x64 Edition, Microsoft Windows Server 2003, Standard Edition (32-bit x86), Microsoft Windows XP Service Pack 2, Microsoft Windows XP Service Pack 3

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