Users cannot use Outlook Web Access for Exchange Server 2007 to open an address book

This article has been archived. It is offered "as is" and will no longer be updated.
SYMPTOMS
In a Microsoft Exchange Server 2007 environment, after you migrate e-mail messages from an Exchange server to a hosted enterprise messaging solution environment, users may find that the addresses of internal recipients in the original messages are converted to SMTP one-off addresses. When these messages are opened, the one-off addresses are resolved to internal recipients.

However, if the msExchQueryBaseDN attribute of a user is set to the distinguished name (also known as DN) ) of an address list, and the user accesses the e-mail messages by using Microsoft Office Outlook Web Access, the SMTP one-off addresses of internal users cannot be resolved, and these address remain as one-off addresses in the messages.
CAUSE
During the process to resolve the address, the DSAccess component is involved. However, the DSAccess component does not support an address list as the base query DN.
RESOLUTION
To resolve this problem, install Update Rollup 8 for Exchange Server 2007 Service Pack 1.

For more information about Update Rollup 8 for Exchange Server 2007 Service Pack 1, see the following Exchange Help topic: For more information about how to obtain the latest Exchange service pack or update rollup, see the following Exchange Help topic:
STATUS
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
MORE INFORMATION
In an Exchange Server 2007 environment, virtual organizations can be specified either by OU or by Address List by using the msExchQueryBaseDN attribute on the user object. For more information, visit the following Microsoft Web site:
hosting
Properties

Article ID: 961443 - Last Review: 01/15/2015 09:25:52 - Revision: 1.1

  • Microsoft Exchange Server 2007 Service Pack 1
  • kbnosurvey kbarchive kbhotfixrollup kbexpertiseadvanced kbqfe KB961443
Feedback