Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

Symptoms

Consider the following scenario:

  • A fallback status point role is enabled on a site server that is running Microsoft System Center Configuration Manager 2007 Service Pack 1 (SP1).

  • Some clients are assigned to this fallback status point.

  • Multiple network adapters are installed on one or more clients.

In this scenario, the fallback status point may stop processing the state message files from clients. Additionally, state messages that have long file names may be stuck in one of the following folders:

  • Statesys.box\Incoming

  • SMS_CCM\FSPStaging

For example, the following state message file has a long file name:

00-04-23-D8-D1-DD00-04-23-D8-D1-DC00-04-75-E7-4D-8D00-06-5B-AB-5E-F400-04-23-D8-C4-0300-04-23-A6-87-2200-04-23-A6-87-2300-04-23-D8-C4-02_CCM Framework Communication State_1000.smxNote If files are stuck in the SMS_CCM\FSPStaging folder, only files that have long names are stuck. State messages that have shorter file names are processed.

If state message files that have long file names are stuck in the Statesys.box\Incoming folder, all state message file processing is blocked.

Additionally, the following errors are logged in the Statesys.log:

CFileQueueMgr::SafeMove - Could not move file 'D:\Program Files (x86)\Microsoft Configuration Manager\inboxes\auth\statesys.box\incoming\00-22-19-34-90-3C00-22-19-34-90-3A00-22-19-34-90-3800-22-19-34-90-3600-1B-21-37-54-4500-1B-21-37-54-4400-1B-21-37-54-4100-1B-21-37-54-40_CCM Framework Communication State_1000.SMX' to 'D:\Program Files (x86)\Microsoft Configuration Manager\inboxes\auth\statesys.box\process\1a6eb8px.SMX', err=3 SMS_STATE_SYSTEM
A state message processing thread ended with a fatal error, backing off... SMS_STATE_SYSTEM

Cause

This problem occurs because the fallback status point queries the client's ID to define the state message file name. If the client ID is missing, the fallback status point queries all MAC addresses of this client to define the state message file name.

If multiple network adapters are installed on this client, the total length of the fallback status point incoming folder name plus the state message file name (all clients' MAC addresses) may exceed the 255 character maximum path length limitation.

Resolution

Service Pack Information

To resolve this problem, obtain the latest service pack for Microsoft System Center Configuration Manager 2007, available from this Microsoft web site: http://www.microsoft.com/download/details.aspx?FamilyID=3318741a-c038-4ab1-852a-e9c13f8a8140
For a list of issues resolved in this service pack, click on the following article number in the Microsoft Knowledgebase:

971348 List of hotfixes and updates that are contained in System Center Configuration Manager 2007 Service Pack 2

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have System Center Configuration Manager 2007 Service Pack 1 installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any previously released hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

System Center Configuration Manager 2007 Service Pack 1

File name

File version

File size

Date

Time

Platform

Fsp.msi

Not applicable

2,766,336

30-Nov-2008

22:00

Not applicable

Fspisapi.dll

4.0.6221.1149

64,864

30-Nov-2008

22:00

x86

Fspisapi.dll

4.0.6221.1149

395,104

30-Nov-2008

22:00

IA-64

Fspisapi.dll

4.0.6221.1149

168,800

30-Nov-2008

22:00

x64

Workaround

To work around the issue, delete the state message files that have long file names from the Statesys.box\Incoming folder or from the \SMS_CCM\FSPStaging folder.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about the fallback status point in System Center Configuration Manager 2007, visit the following Microsoft Web site:

http://technet.microsoft.com/en-us/library/bb694178.aspxFor more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×