Troubleshooting shutdown problems in Windows XP

Support for Windows XP has ended

Microsoft ended support for Windows XP on April 8, 2014. This change has affected your software updates and security options. Learn what this means for you and how to stay protected.

This article has been archived. It is offered "as is" and will no longer be updated.
Source: Microsoft Support
RAPID PUBLISHING
RAPID PUBLISHING ARTICLES PROVIDE INFORMATION DIRECTLY FROM WITHIN THE MICROSOFT SUPPORT ORGANIZATION. THE INFORMATION CONTAINED HEREIN IS CREATED IN RESPONSE TO EMERGING OR UNIQUE TOPICS, OR IS INTENDED SUPPLEMENT OTHER KNOWLEDGE BASE INFORMATION.
Symptom


When you shut down a computer it may crash, restart, or display other errors. This resolution applies to both Windows 2000 and Windows XP. The steps are the same.

 
Cause


One or more drivers may need to be updated.
Resolution


To resolve this problem, follow these steps:

1.       Click Start, click Run, and then type SIGVERIF.EXE.

2.       Click Advanced.

3.       Click Look for other files that are not digitally signed.

4.       In the Look in this folder dialog box, type c:\windows\system32\drivers.

5.       Click OK.

6.       Click Start.

7.       When complete, click Start, click Run, and then type SIGVERIF.TXT.

Note      The SIGVERIF.TXT logfile will contain all the drivers on the system.

8.       Make note of unsigned drivers and drivers that are not signed by NT5.CAT,
NT5INF.CAT, SP1.CAT, SP2.CAT, or SP3.CAT. These are the third-party drivers on the
system.

Note      A third-party driver that is signed may still cause problems.

9.       Boot to the recovery console and rename all of the drivers that you noted.

Important           Do this from recovery console so that if there is a problem you can return the computer to a state to where it boots. Some drivers, such as mass storage drivers, cannot be renamed since the computer needs them to boot.

Note      If you have renamed all the other drivers to that only the mass storage driver is left to be renamed, check for updated versions of the mass storage driver.

10.   Start the computer and login.

Note      You may receive errors because certain files were renamed. Ignore these errors for now. This is a test.

11.   Once you have logged on, try to shut down the computer. If you can shut down the computer,  add each driver back, one at a time, until you find the driver that is causing the shutdown problems.

12.   Once you find the driver that is causing the shutdown problems, try to find an updated version of that driver or use the inbox driver for the device.

Note      Windows Update contains updated drivers that come from manufacturers. These may not be Microsoft drivers.

 

 
More Information


 

 
DISCLAIMER
MICROSOFT AND/OR ITS SUPPLIERS MAKE NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY, RELIABILITY OR ACCURACY OF THE INFORMATION CONTAINED IN THE DOCUMENTS AND RELATED GRAPHICS PUBLISHED ON THIS WEBSITE (THE “MATERIALS”) FOR ANY PURPOSE. THE MATERIALS MAY INCLUDE TECHNICAL INACCURACIES OR TYPOGRAPHICAL ERRORS AND MAY BE REVISED AT ANY TIME WITHOUT NOTICE.

TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, MICROSOFT AND/OR ITS SUPPLIERS DISCLAIM AND EXCLUDE ALL REPRESENTATIONS, WARRANTIES, AND CONDITIONS WHETHER EXPRESS, IMPLIED OR STATUTORY, INCLUDING BUT NOT LIMITED TO REPRESENTATIONS, WARRANTIES, OR CONDITIONS OF TITLE, NON INFRINGEMENT, SATISFACTORY CONDITION OR QUALITY, MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE, WITH RESPECT TO THE MATERIALS.
Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.
Properties

Article ID: 967534 - Last Review: 01/16/2015 11:09:16 - Revision: 2.0

Microsoft Windows XP Home Edition, Microsoft Windows 2000 Standard Edition

  • kbnosurvey kbarchive kbnomt kbrapidpub KB967534
Feedback