You are currently offline, waiting for your internet to reconnect

The FSCDiag.exe tool in Forefront Security for SharePoint prompts you to add "Exchange" versions instead of "SharePoint" versions

This article has been archived. It is offered "as is" and will no longer be updated.
When you run the Forefront Security Diagnostic tool (FSCDiag.exe) on a computer that is running Microsoft Forefront Security for SharePoint, you experience the following symptoms:
  • Information in the tool mentions "Exchange" instead of "SharePoint." For example, you receive the following messages when you run the tool:

    Message 1
    Add Exchange file versions --- Yes(Y)/No(N) ?
    Message 2
    Add Exchange agents.config file --- Yes(Y)/No(N) ?
  • You receive the following error message when you follow the steps in the tool:
    Storing Exchange file version; Can't open registry key: SOFTWARE\Microsoft\Exchange\Setup
To resolve this problem, install Forefront Security for SharePoint Service Pack 3 (SP3). For more information, click the following article number to view the article in the Microsoft Knowledge Base:
967995 Description of Forefront Security for SharePoint with Service Pack 3
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
More information
For more information about how to use the Forefront Security Diagnostic tool, visit the following Microsoft Web site:
FSSP SP3 fscdiag.exe versions Exchange SharePoint FSSP file versions

Article ID: 968158 - Last Review: 01/15/2015 10:59:44 - Revision: 2.0

Microsoft Forefront Security for SharePoint, Microsoft Forefront Security for SharePoint Service Pack 1, Microsoft Forefront Security for SharePoint Service Pack 2

  • kbnosurvey kbarchive kbqfe kbexpertiseinter kbsurveynew kbprb KB968158