Outlook 2007: Asynchronous Server Connections are not disconnected when Public Folder Server is down

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Source: Microsoft Support
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Symptom


Your Exchange server continues to crash (or failover on a cluster server) because it is running out of Nonpaged Pool memory. When you troubleshoot the problem you notice the following items:



-       If you check the number of connections to the server (for example, using Netstat) the number of connections from an Outlook client continues to increase at the rate of about 1 connection every 5 minutes.

-       If you disable Asynchronous communication on the Outlook client using the following registry data, the number of connections does not continue to increase from the client.

Key: HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Outlook\RPC

DWORD: AsyncRPCMask
Value: 1

DWORD: AsyncRPCBits
Value: 0



NOTE1: Disabling Asynchronous communication with the Exchange server is not normally intended as a fix or resolution to the problem, it is intended as a troubleshooting step for verification that you are encountering the problem described in this article.

NOTE2: Running Outlook with asynchronous RPC communication disabled is a tested configuration for Outlook 2007. With asynchronous communication disabled in Outlook 2007 you may encounter more temporary hangs. So, you should restore the default settings as soon as you finish testing Outlook with this registry information. The ultimate resolution for this issue will come from changes you make on your Exchange server.
Cause


This problem can occur if all of the following are true:

-       You are using Outlook 2007

-       Outlook is using Asynchronous communication with the Exchange server

-       The Outlook client is using Windows XP

-       The default public folder store is on a different Exchange server than the server containing the mailbox you are connecting to with Outlook.The Information Store service on the Exchange server with the default public folder store is stopped.


NOTE: The problem does not occur if the Outlook client is using Windows Vista or Windows Server 2003.
Resolution


To resolve this problem make sure the Information Store service is running on the Exchange server designated as the default public folder store for user mailboxes. You can check the server specified as the default public folder store using the following steps in Exchange 2003:



1. Start Exchange System Manager.

2. Right-click the mailbox store and click Properties

3. Observer the server listed in the Default public store box.

4. If necessary, click Browse to locate and select a different public folder store (for example, the current public folder store is on a Frontend Exchange server)

Microsoft recommends that you do not run mailbox or public folder databases on front-end servers. This is because mailbox or public folder databases are not necessary on front-end servers, because front-end servers do not host mailboxes.
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Article ID: 969843 - Last Review: 01/16/2015 11:10:09 - Revision: 3.0

Microsoft Office Outlook 2007

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