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Internet Explorer 9 and Internet Explorer 8 take longer than expected to start

If you are a Small Business customer, find additional troubleshooting and learning resources at the Support for Small Business site.
 
Symptom
When you start Windows Internet Explorer, you notice that the program takes longer than expected to start.
Cause
This behavior can occur if an installed Internet Explorer add-in is damaged or if an installed add-in is incompatible with Internet Explorer. This behavior may be more visible in Internet Explorer 9 and in Internet Explorer 8 because of changes in the way that Internet Explorer 9 and Internet Explorer 8 handle the Internet zones list. 

This behavior can also occur if you use Spybot, and the Spybot Immunize feature is enabled. 
Resolution
To resolve this behavior, troubleshoot the add-ins to determine which add-in may be causing the behavior, and then disable or uninstall the add-in. Then, contact the manufacturer of the add-in for support for that add-in.

To do this, follow these steps:

Note If you currently have Spybot installed, and you have the Immunize feature enabled, you must disable this feature until the behavior is resolved. If you don't know how to disable the Immunize feature, contact the vendor for more help. 

Step 1: Run Internet Explorer in "No Add-ons" mode

Internet Explorer 9 and Internet Explorer 8 add-ins, such as ActiveX controls and browser toolbars, are used by some websites to provide an improved browsing experience. An error can occur if an add-in is damaged or if an add-in conflicts with Internet Explorer. 

To determine whether the error is caused by an add-in, run Internet Explorer in "No Add-ons" mode.

To do this, follow these steps: 
  1. Click Start, and then type Internet Explorer in the Start Search box.
  2. Click Internet Explorer (No Add-ons). Internet Explorer opens without add-ins, toolbars, or plug-ins.
  3. Test Internet Explorer to verify that it works correctly. If issues still occur, go to Step 3.

If no errors occur, the problem is caused by one of the add-ins that typically loads together with Internet Explorer 9 and with Internet Explorer 8. In this case, go to Step 2 to determine which add-in is causing the behavior.  

Step 2: Use the Manage Add-ons tool

Use the Manage Add-ons tool in Internet Explorer 9 and Internet Explorer 8 to disable each add-in separately to determine which add-in is causing errors. 

To do this, follow these steps:  
  1. Open Internet Explorer 9 or Internet Explorer 8.
  2. Click Tools, point to Manage Add-ons, and then click Enable or Disable Add-ons.
  3. In the Show box, select Add-ons that have been used by Internet Explorer.

    Note This displays all add-ins that are installed on the computer.
  4. Select each item in the add-ins list one at a time, and then click Disable under Settings.
  5. When you have disabled all the items in this list, click OK.
  6. Exit and then restart Internet Explorer.
  7. If errors do not occur, repeat steps 1 through 6, except do the following in steps 4 and 5:
    • In step 4, select one item in the add-in list, and then click Enable.
    • In step 5, click OK after you disable the single add-in.
  8. Repeat this procedure until the error occur again.

After you determine which add-in causes the errors, you can disable that add-in. Or, you can uninstall the software that installs the add-in. For additional troubleshooting and support, we also recommend that you contact the software vendor that manufacturers the add-in. 

Step 3: Reset Internet Explorer 8 or Internet Explorer 9 settings

To determine whether a performance issue or an error message is caused by configuration settings, reset Internet Explorer 8 or Internet Explorer 9 to its default configuration. This step will also disable any add-ins, plug-ins, or toolbars that are installed. Although this solution is quick, it also means that you must reinstall these add-ins if you want to use them in the future.

To reset the program settings, follow these steps: 
  1. Start Internet Explorer 8 or Internet Explorer 9.
  2. Click Tools, and then click Internet Options.
  3. Click the Advanced tab.
  4. Under Reset Internet Explorer Settings, click Reset.
More Information
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.
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Article ID: 969938 - Last Review: 06/29/2012 12:44:00 - Revision: 9.1

  • Windows 7 Enterprise
  • Windows 7 Enterprise N
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Home Premium N
  • Windows 7 Professional
  • Windows 7 Professional N
  • Windows 7 Starter
  • Windows 7 Starter N
  • Windows 7 Ultimate
  • Windows 7 Ultimate N
  • Windows Internet Explorer 8
  • Windows Internet Explorer 9
  • kbrapidpub kbnomt KB969938
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