Your voice is discontinuous when you use Microsoft Office Communicator 2007 R2 to make a call on a Windows 7 or a Windows Server 2008 R2-based remote computer

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Symptoms
When you use Microsoft Office Communicator 2007 R2 to make a call from a remote computer that is running Windows 7 or Windows Server 2008 R2, your voice is discontinuous.
Cause
When you make a call through Microsoft Office Communicator 2007 R2 on a remote computer that is running Windows 7 or Windows Server 2008 R2 with redirected audio streams, the audio engine usually produces 50 milliseconds (ms) of data for every 50ms. However, only 20ms of data can be processed by Office Communicator 2007 R2. Therefore, the other 30ms of data are lost in Office Communicator 2007 R2.
Resolution
To resolve this issue, apply the update that is described in the following Microsoft Knowledge Base article:
969695 Description of the Communicator 2007 R2 hotfix rollup package: June 2009
Status
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
More information
There is a long audio latency period when you use Remote Desktop with redirected audio streams. Therefore, echo cancellation does not work when you make calls in a Remote Desktop session. Making VoIP calls during a Remote Desktop session is not supported. This update fixes the audio quality problems that are described in the Symptoms section. Therefore, after you apply this update, you may have a VoIP conversation if you use a headset. However, this cannot be guaranteed.
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Article ID: 972090 - Last Review: 01/16/2015 03:58:36 - Revision: 3.0

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