You are currently offline, waiting for your internet to reconnect

Error message when you save a filter as default in the Exchange Management Console (EMC) and then restart the EMC: "The search filter is invalid"

SYMPTOMS
In a Microsoft Exchange Server 2007 environment, when you save a filter as default in the Exchange Management Console (EMC) and then restart the EMC, you receive a "The search filter is invalid" error message. Additionally, the default filter does not work. Therefore, you have to remove and then re-create the default filter.

The following is an example of the error message that you receive:
Active Directory Operation failed on <domain controller>. This error is not retriable. Active Directory Response: The search filter is invalid. It was running command “get-recipient –resultsize ‘1000’ –sortby “displayname” – RecipientType ‘usermailbox’ –filter “{serverlegacydn –eq””}“
CAUSE
The filter is saved with the incorrect syntax.
RESOLUTION
To resolve this problem, install the following update rollup:
971534 Description of Update Rollup 1 for Exchange Server 2007 Service Pack 2
STATUS
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
Properties

Article ID: 972426 - Last Review: 11/19/2009 20:33:23 - Revision: 1.0

Microsoft Exchange Server 2007 Enterprise Edition, Microsoft Exchange Server 2007 Standard Edition

  • kbsurveynew kbexpertiseinter kbfix kbhotfixrollup kbqfe KB972426
Feedback
s.dqp0';m.content='true';document.getElementsByTagName('head')[0].appendChild(m);" onload="var m=document.createElement('meta');m.name='ms.dqp0';m.content='false';document.getElementsByTagName('head')[0].appendChild(m);" src="http://c1.microsoft.com/c.gif?">