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Symptoms

In Windows XP or in Windows Server 2003, you use Windows Internet Explorer 8 to visit a Microsoft Office SharePoint Portal Server site through an HTTPS connection. In this scenario, when you select Explorer View on the site, the Web folder does not appear. Additionally, you see an error message in the frame where the Web folder should be displayed:

Please wait while Explorer View is loaded. If Explorer View does not appear, your browser may not support it.


Notes

  • This issue also occurs when you use HTTP connection, and the WebClient service is disabled.

  • This issue also occurs in Windows Vista and in Windows Server 2008 if the WebClient Service is disabled.


Cause

This issue occurs because of an incompatibility that is introduced by the improvements to Internet Explorer 8's URL handling logic, when it opens certain WebDav URLs.

Resolution

Security update information

To resolve this problem, install the most recent cumulative security update for Windows Internet Explorer. To do this, visit the following Microsoft Web site:

http://update.microsoft.comFor more technical information about the most recent cumulative security update for Windows Internet Explorer, visit the following Microsoft Web site:

http://www.microsoft.com/technet/security/current.aspxNote This update was first included in security update 974455 (MS09-054). For more information, click the following article number to view the article in the Microsoft Knowledge Base:

974455 MS09-054: Cumulative Security Update for Internet Explorer

Before you apply this hotfix, try to resolve this problem by using the following method that is appropriate for your situation:

  • If you are running Windows Server 2003, start the WebClient service.

Hotfix information

A supported hotfix is now available from Microsoft. However, it is intended to correct only the problem that is described in this article. Apply it only to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

To resolve this problem immediately, contact Microsoft Customer Support Services to obtain the hotfix. For a complete list of Microsoft Customer Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:

http://support.microsoft.com/contactus/?ws=supportNote In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To install this hotfix, you must have Internet Explorer 8 installed on one of the following operating systems:

  • Windows XP SP2 or Windows XP SP3

  • Windows Server 2003 SP2

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

Registry information

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:

322756 How to back up and restore the registry in WindowsAfter you install this hotfix on the computer, you must add a registry value to enable the hotfix. To do this, follow these steps:

  1. Click Start, click Run, type regedit, and then press ENTER.

  2. Locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\MAIN\FeatureControl

  3. On the Edit menu, point to New, and then click Key.

  4. Type the following name, and then press ENTER:

    FEATURE_WEBFOLDER_DIRECTNAVIGATE_KB972584

  5. Right-click FEATURE_WEBFOLDER_DIRECTNAVIGATE_KB972584, point to New, and then click DWORD Value.

  6. Type iexplore.exe, and then press ENTER.

  7. Right-click iexplore.exe, and then click Modify.

  8. In the Value data box, type 1, and then click OK.

  9. Exit Registry Editor.

File information

The English version of this has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Internet Explorer 8 for Windows XP, x86-based versions

File name

File version

File size

Date

Time

Platform

Ieframe.dll

8.0.6001.22892

11,066,368

24-Jun-2009

15:50

x86

Internet Explorer 8 for Windows Server 2003, x86-based versions

File name

File version

File size

Date

Time

Platform

Ieframe.dll

8.0.6001.22892

11,066,368

24-Jun-2009

21:21

x86

Note

After you apply this hotfix and the registry key:

  • Web Folders behave the same in Internet Explorer 8 on Windows XP or on Windows Server 2003 as they do in Internet Explorer 7 on Windows XP or on Windows Server 2003.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about the Web Folder Behaviors, visit the following Microsoft Web site:

http://msdn.microsoft.com/en-us/library/ms531432(VS.85).aspxFor more information about the Desktop Experience feature, visit the following Microsoft Web site:

http://technet.microsoft.com/en-us/library/cc772567.aspx

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