A hotfix is available that addresses unresponsiveness when a file system minifilter driver is running on a computer that is running Windows Server 2003

Support for Windows Server 2003 ended on July 14, 2015

Microsoft ended support for Windows Server 2003 on July 14, 2015. This change has affected your software updates and security options. Learn what this means for you and how to stay protected.

This article has been archived. It is offered "as is" and will no longer be updated.
Symptoms
A computer that is running Windows Server 2003 stops responding (hangs) occasionally if some file system minifilter drivers that depend on the Filter Manager (fltmgr.sys) are running. For example, this may occur if you have Server for Network File System (NFS) running on the computer.

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Cause
This problem occurs because of a deadlock situation during the initialization of some file system minifilter drivers.
Resolution
Note: Though rare, this issue may occur even with the hotfix below installed. In these cases, the workaround is to change the startup type of the 'Server for NFS' or 'Client for NFS' services to MANUAL and manually start the service after system bootup is complete.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 2 installed on the computer. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with Service Pack 2, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Fltmgr.sys5.2.3790.4565132,09604-Aug-200913:18x86
Windows Server 2003 with Service Pack 2, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Fltmgr.sys5.2.3790.4565475,64804-Aug-200902:04IA-64
Windows Server 2003 with Service Pack 2, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Fltmgr.sys5.2.3790.4565228,86404-Aug-200902:04x64
Status
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
More information
For more information about the Filter Manager, visit the following Microsoft Developer Network Web site:For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
hang deadlock during service filter driver initialization
Properties

Article ID: 973495 - Last Review: 01/16/2015 04:02:29 - Revision: 4.0

  • Microsoft Windows Server 2003 Service Pack 2
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