You are currently offline, waiting for your internet to reconnect

The folders returned during an IMAP4 LSUB command are incorrect on an Exchange Server 2007 mailbox

When an IMAP4 client is used to subscribe to a folder, the folder name appear incorrectly on the client and the Exchange server.
If an LSUB command is used to the Microsoft Exchange Server 2007 mailbox, the folder names that are returned may include a question mark (?). For example, you have a folder that is named AAA\£BBB, the incorrect response to the LSUB command of AAA\?BBB could be sent. This can occur on any folders that contain an extended character.

Note Microsoft Office Outlook Express and Windows Mail client do not have this problem.
This problem occurs because Exchange Server 2007 does not encode the responses correctly in UTF-7 format. This issue happens as typically an LSUB command is sent to the server to check upon subscription status. At this point, Exchange responds with a wrongly encoded folder name and this can cause a difference between the client and the server.
To fix this problem, apply the following update rollup:
972076 Description of Update Rollup 2 for Exchange Server 2007 Service Pack 2
For more information about how to use the LSUB command in an IMAP4 client, visit the following IETF Web site:
For more information about UTF-7 format, visit the following IETF Web site:
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Article ID: 974679 - Last Review: 01/22/2010 22:29:19 - Revision: 1.1

  • Microsoft Exchange Server 2007 Service Pack 2
  • kbsurveynew kbhotfixrollup kbexpertiseinter kbqfe KB974679