Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

Symptoms

Consider the following scenario:

  • You deploy Microsoft Exchange Server 2010 in an environment that already has Microsoft Exchange Server 2007.

  • Exchange 2010 and Exchange 2007 are separated by Microsoft Internet Security and Acceleration (ISA) Server 2006 or Microsoft Forefront Threat Management Gateway (TMG) 2010.

  • You try to move a mailbox from Exchange 2007 to Exchange 2010 by using the New-MoveRequest task on the Exchange 2010 Microsoft Management Console (MMC) snap-in.


In this scenario, the operation fails together with the following error message:

Error: MapiExceptionNetworkError: Unable to make connection to the server. (hr=0x80040115, ec=-2147221227)



Note The supported fix for Forefront TMG 2010 is included in Forefront TMG 2010 Service Pack 1 (SP1).

Cause

This problem occurs because ISA Server 2006 or Forefront TMG 2010 does not forward some error codes that are generated on the server-side remote procedure calls (RPC) in this scenario.

Resolution

Service pack information

This problem is fixed in Forefront TMG 2010 Service Pack 1.

For more information about how to obtain Forefront TMG 2010 Service Pack 1, click the following article number to view the article in the Microsoft Knowledge Base:

981324 List of problems that are fixed in Forefront Threat Management Gateway 2010 Service Pack 1

Hotfix rollup information



Hotfix installation information

To resolve this problem, follow these steps:

  1. Install the hotfix rollup package that is described in the following Microsoft Knowledge Base article:

    976301 Description of the ISA Server 2006 hotfix package: October 25, 2009

  2. Start Notepad, and then copy the following script into a Notepad file.

        Dim oFPC
    Dim oFirewallFilter
    Dim oVPS

    on error resume next

    err.Clear

    Set oFPC = CreateObject("FPC.Root")

    'Get the filter admin object
    Set oFirewallFilter = oFPC.GetContainingArray.Extensions.ApplicationFilters("{E331F638-AB86-4AA5-9B6A-2B0248C7B4FB}")
    if oFirewallFilter is nothing then
    Wscript.Echo "RPC filter ({E331F638-AB86-4AA5-9B6A-2B0248C7B4FB}) is not installed in array"
    WScript.Quit
    end if

    'Get the filters vendor parameters set object
    Set oVPS = oFirewallFilter.VendorParametersSets("{E331F638-AB86-4AA5-9B6A-2B0248C7B4FB}")

    'If this vendor parameters set does not exists, create it
    If oVPS Is Nothing Then
    WScript.Echo "Adding vendor parameters set ({E331F638-AB86-4AA5-9B6A-2B0248C7B4FB})"
    err.Clear
    Set oVPS = oFirewallFilter.VendorParametersSets.Add("{E331F638-AB86-4AA5-9B6A-2B0248C7B4FB}",False)
    oFirewallFilter.VendorParametersSets.Save
    End If

    'Add the needed parameters

    oVPS.Value("ForwardNotRegisteredError") = 1

    oVPS.Save

    'Inform the user of the result
    if err.Number <>0 then
    Wscript.Echo "Fail to set parameters. error code is:" & err.number & " Desc:" & err.description
    else
    Wscript.Echo "Paramters were successfully added"
    end if
  3. Save the file as a Microsoft Visual Basic script file by using the .vbs file name extension. For example, save the file by using the following name:
    EnableKB976545.vbs

  4. Double-click the .vbs file to run it.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Forefront TMG 2010 Service Pack 1.

References

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×