You are currently offline, waiting for your internet to reconnect

You cannot delete a custom many-to-many relationship after you run the Microsoft.Crm.SE.FixMissingBulkDeleteFailureRelationship.exe tool in Microsoft Dynamics CRM 4.0

SYMPTOMS
Consider the following scenario in Microsoft Dynamics CRM 4.0. You create a custom many-to-many relationship. Then, you run the Microsoft.Crm.SE.FixMissingBulkDeleteFailureRelationship.exe tool. In this scenario, you cannot delete the custom many-to-many relationship.

Note To obtain the Microsoft.Crm.SE.FixMissingBulkDeleteFailureRelationship.exe tool, apply the hotfix that is described in the following Microsoft Knowledge Base (KB) article:

954322 Error message when you import some customizations to an upgraded installation of Microsoft Dynamics CRM 4.0: "Either the file could not be uploaded or Import failed"
CAUSE
This problem occurs because there is an error in the Microsoft.Crm.SE.FixMissingBulkDeleteFailureRelationship.exe tool.
RESOLUTION
This problem is fixed in the latest cumulative update rollup for Microsoft Dynamics CRM 4.0.
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
949256 Microsoft Dynamics CRM 4.0 updates and hotfixes

After you install the latest update rollup, you must contact Microsoft Dynamics CRM Support if you have relationships that are affected by this issue.
STATUS
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
Properties

Article ID: 978103 - Last Review: 12/17/2009 16:20:53 - Revision: 1.0

Microsoft Dynamics CRM 4.0

  • kbfix kbexpertiseinter kbsurveynew kbmbsmigrate kbqfe KB978103
Feedback