You are currently offline, waiting for your internet to reconnect

Event ID 2156 is logged on a computer that is running Exchange Server 2010

SYMPTOMS
On a computer that is running Microsoft Exchange Server 2010, the following error message is logged in the Application log:
Log Name:      ApplicationSource:        MSExchangeReplEvent ID:      2156Task Category: ServiceLevel:         ErrorKeywords:      ClassicUser:          N/ADescription:The log copier for database '<database name>' could not send a log file to server '<target server which hold the passive copy>' because an I/O error occurred while attempting to access file '<database log file>' on source server <the server which holds the active copy>. Error: The request could not be performed because of an I/O device error.
After this error message is logged, you cannot move the database or copy a log file.

Note This problem may be caused by a hard disk issue. You can determine whether this problem is caused by a hard disk issue by checking the system event logs. If this problem is caused by a hard disk issue, change the hard disk and install the hotfix that is mentioned in the "Resolution" section.
CAUSE
When you copy a log file from the active copy to the passive copy, the Exchange Server 2010 server tries to verify the log file first. If the log file has a destroyable block that is caused by a hard disk issue, the read operation fails. Additionally, an I/O exception is generated and replication stops. In this situation, a cluster failover should occur on the Exchange Server 2010 server. However, a cluster failover does not occur as expected. Therefore, the log file is locked.
RESOLUTION
To fix this problem, install Update Rollup 2 for Exchange Server 2010.
For more information about Update Rollup 2 for Exchange 2010, click the following article number to view the article in the Microsoft Knowledge Base:
979611 Description of Update Rollup 2 for Exchange Server 2010: February 18, 2010
STATUS
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
Properties

Article ID: 980262 - Last Review: 03/04/2010 23:55:47 - Revision: 1.0

Microsoft Exchange Server 2010 Standard, Microsoft Exchange Server 2010 Enterprise

  • kbsurveynew kbhotfixrollup kbexpertiseinter kbqfe KB980262
Feedback
html>ms.dqp0';m.content='true';document.getElementsByTagName('head')[0].appendChild(m);" onload="var m=document.createElement('meta');m.name='ms.dqp0';m.content='false';document.getElementsByTagName('head')[0].appendChild(m);" src="http://c1.microsoft.com/c.gif?"> = ""; document.write(" guage in languagesListForLargeScreens track by $index -->
Venezuela - Español
://c1.microsoft.com/c.gif?DI=4050&did=1&t="> = 1; var varClickTracking = 1; var varCustomerTracking = 1; var Route = "76500"; var Ctrl = ""; document.write(" cument.createElement('meta');m.name='ms.dqp0';m.content='false';document.getElementsByTagName('head')[0].appendChild(m);" src="http://c1.microsoft.com/c.gif?">