You are currently offline, waiting for your internet to reconnect

You receive an error message when you install Office Communications Server 2007 R2 Web Service Provider

SYMPTOMS
When you install the latest update for Microsoft Office Communications Server 2007 R2 Web Service Provider, you receive the following error message:
Microsoft Office Communications Server 2007 R2 Web Service Provider installation requires that Unified Communications Managed API Redistributable version 3.5.6907.170 or greater is already installed. Apply the latest update for ucmaredist available from http://support.microsoft.com/kb/968802.
CAUSE
This problem occurs because the latest patch for Office Communications Server 2007 R2 Web Service Provider requires new APIs. These APIs are added by a later patch for Unified Communications Managed API Redistributable. Additionally, an internal check is added in the latest patch for Office Communications Server 2007 R2 Web Service Provider. This internal check determines whether the required Unified Communications Managed API Redistributable patch is installed.
RESOLUTION
To resolve this problem, follow these steps:
  1. Download and then install the required patch for Unified Communications Managed API Redistributable that is described in the following Microsoft Knowledge Base article:
    976657 Description of the cumulative update for Office Communications Server 2007 R2, Unified Communications Managed API 2.0 Core Redist 64-bit: April 2010
  2. Download and install the latest patch for Office Communications Server 2007 R2 Web Service Provider. To do this, visit the following Microsoft website:
STATUS
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
Properties

Article ID: 981256 - Last Review: 10/06/2011 19:00:00 - Revision: 2.0

Microsoft Office Communications Server 2007 R2 Enterprise Edition, Microsoft Office Communications Server 2007 R2 Standard Edition

  • kbfix kbexpertiseinter kbqfe kbsurveynew KB981256
Feedback