The lookup fields are not updated when you run the Microsoft Dynamics CRM SDK import process to update Microsoft Dynamics CRM 4.0

This article has been archived. It is offered "as is" and will no longer be updated.
SYMPTOMS
When you run the Microsoft Dynamics CRM Software Development Kit (SDK) import process to update Microsoft Dynamics CRM 4.0, the lookup fields are not updated.
CAUSE
This problem occurs because the mappings for lookup fields are unavailable in the update mode. Therefore, the Microsoft Dynamics CRM SDK import process ignores the lookup fields.
RESOLUTION
Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows


This problem is fixed in the latest cumulative update rollup for Microsoft Dynamics CRM 4.0.
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
949256 Microsoft Dynamics CRM 4.0 updates and hotfixes

To enable this hotfix on the computer that is running Microsoft Dynamics CRM 4.0, follow these steps:
  1. Under the
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM\
    registry subkey on the Microsoft Dynamics CRM server, add the following DWORD registry entry:
    AllowLookupUpdateDuringImport
  2. Set the value of the registry entry that you just added to 1.
Note This problem was originally fixed in Update Rollup 10 for Microsoft Dynamics CRM 4.0.
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
979347 Update Rollup 10 for Microsoft Dynamics CRM 4.0 is available
STATUS
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
MORE INFORMATION
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
For more information about Microsoft Business Solutions CRM software hotfix and update package terminology, click the following article number to view the article in the Microsoft Knowledge Base:
887283 Microsoft Business Solutions CRM software hotfix and update package naming standards
Properties

Article ID: 981837 - Last Review: 12/12/2015 03:56:21 - Revision: 1.0

Microsoft Dynamics CRM 4.0

  • kbnosurvey kbarchive kbfix kbexpertiseinter kbsurveynew kbmbsmigrate kbqfe KB981837
Feedback