Change the language Office uses in its menus and proofing tools

Microsoft virtual support agent icon

Try the Microsoft Virtual Agent

Our Virtual Agent can help answer your Office language questions.

There are three areas in Microsoft Office where you may want to change the language.

  • Editing or Authoring is the language in which you write and edit your content. You may need to install an associated keyboard for this language via Windows settings.

  • Proofing tools are spelling and grammar check. Typically, you'll set this language to be the same as the editing or authoring language.

  • Display language is for all the buttons, menus, and controls in Office.

You can set the display and editing or authoring languages independently from each other. For example, you may want the display language to be English, but the document you're writing or editing is in French.

Note: If you want to completely change Office, permanently, to a different language you'll get the best results if you first set that to be your default display language in Windows as well. For more information on doing that see this article for Windows 10 or this article for Windows 7 or 8.

Note:  If you're using Office 365 and the commands available are different from what's shown here, expand the Configure Office language for Office 2016 or earlier section and follow the instructions there.

In Office, the language options are in the Office Language Preferences dialog box. The display and authoring languages can be set independently. For example, you could have everything match the language of your operating system, or you could use a combination of languages for your operating system, authoring, and display.

To configure the display language:

  1. Within any Office application, select File > Options > Language.

  2. Under Office display Language, make sure the display language you want Office to use is listed.

    Office display language

  3. Select the language you want, and then select Set as Preferred. If you want your Office display language to match the display language you have for Windows, select Match Microsoft Windows [Language].

  4. If the language you want is not listed, select Install additional display languages from Office.com and follow the instructions there.

To configure the authoring and proofing language:

  1. Within any Office application, select File > Options > Language.

  2. Under Office authoring languages and proofing, make sure the language you want to use for authoring your document is listed.

    Office authoring languages and proofing

  3. If the language you want appears in the list, select it, and then select Set as Preferred. If the language you want is not listed, select Add a language, and then follow the instructions in the Add an authoring language dialog box.

  4. If the language accessory pack includes proofing tools for that language, its status appears as Proofing installed. If the status is Proofing available, click the link to install the proofing tools.

In Office, the language options are in the Set the Office Language Preferences dialog box. The display and help languages can be set independently. For example, you could have everything match the language of your operating system, or you could use a combination of languages for your operating system, editing, display, and Help.

To configure the editing and proofing language:

  1. Within any Office application, select File > Options > Language.

    The dialog box where you can add, select, or remove the language Office uses for editing and proofing tools.
  2. If your language already appears among the editing languages press Set as Default. Otherwise select the language from the Add additional editing languages list then press the Add button. The new language will appear in the list of editing languages.

If the Keyboard Layout shows as Enabled, you're all set for editing. If it says Not enabled in the Keyboard Layout column follow these steps to enable it:

  1. Click the Not enabled link.

  2. In the Add Languages dialog box, press Add a language, select your language in the list, and then press Add.

  3. Close the Add Languages dialog box. Your language should display as Enabled under Keyboard Layout in the Choose Editing Languages section.

Under Proofing, if your language shows as Installed, you're ready to go. Otherwise press Not installed and Office will take you to a page where you can download the necessary Language Accessory Pack for that language. Follow the instructions on that page to download and install the pack, then come back to the Office Language Preferences dialog box to confirm that it's now installed.

To configure the display and help languages:

  • Within any Office application, select File > Options > Language.

    The dialog that allows you to select the language that Office will use for it's buttons, menus and help.

If you've already set your Microsoft Windows display language to be the language you want Office to display in you can leave this set to Match Microsoft Windows. Otherwise select your language and press Set as Default to move that language to the top of the list. The language that is listed first is the one Office will use for its menus and buttons. Please note, if your Windows display language is not also installed in Office, your Office display language will appear in the next language in the display list.

Repeat to configure your help language if you want to.

If the language you want isn't available...

Download the proper Language Accessory Pack for the language you want to use from this page: Language Accessory Pack for Office. The Language Accessory Pack contains the display and proofing tools for most languages, but you can still choose to have your display in one language and editing or authoring in another.

Microsoft Office for Mac already contains all of the available languages, so there's nothing to download. To configure Office to use those languages follow these steps:

Image of a grey line

User Interface - The display language for Office for Mac uses the primary language set for operating system. To change the display language for Office for Mac, you need to set a different primary language for your operating system:

  1. On the Apple menu, choose System Preferences > Language & Region

  2. In the Preferred Languages list, set the desired language to be your primary language by dragging it to the top of the list.

  3. If the language you want doesn't appear just press the + sign and add it.

  4. You'll have to restart your Office application for this change to take effect.

Image of a grey line

Editing - Setting the editing language depends on the program you're working in.

Word and PowerPoint

To change your editing language in Word for Mac or PowerPoint for Mac, go to Tools > Language, select your language, and select OK.

To make it the default for all new documents select Default.

Excel

To change your editing language in Excel for Mac, go to Tools > Language, select your language, and select OK.

OneNote

To change your editing language in OneNote for Mac, go to Tools > Set Proofing Language, select your language, and select OK.

Image of a grey line

User Interface & Editing - The display and keyboard languages for Office for Android is the same as the language that the device is set to. You can configure those by going to Settings > Language and Input.

Image of a grey line

Proofing - On Android you can change the proofing language in Word.

In Word on your Android phone, tap Edit  Edit button at the top of your screen, and then tap Proofing and Language under Review.

In Word on your Android tablet go to the Review tab and you can select your proofing language from the ribbon.

Image of a grey line

User Interface & Editing - The display and keyboard languages for Office for iOS are the same as the language that the device is set to. See Change the language on your iPhone or iPad for instructions.

Image of a grey line

Proofing - On iOS you can change the proofing language in Word.

In Word on your iPhone, tap Edit Edit button , tap Home > Review > Proofing tools, and then tap Proofing Language.

In your document, on the Review tab, tap Spell Check Spell check , and then tap Proofing Language.

Turn on spelling

Image of a grey line

User Interface & Editing - The display and keyboard languages for Office for Windows Mobile are the same as the language that Windows is set to.

Image of a grey line

Proofing - On Windows Mobile you can change the proofing language in Word.

In your document, on the Review tab, you can select the proofing language from the ribbon.

Image of a grey line

User Interface - The best way to set the display language in Office for the web is to set the language in the host where your documents live. That's usually OneDrive, SharePoint, Dropbox, etc. When you open a document from one of those sites, Office Online will use the display language you have that service set to.

Tip: If you're using a personal Microsoft account, you can choose your preferred display language in your profile settings at https://account.microsoft.com/profile.

Image of a grey line

To set the proofing tools language in your app go to the Review tab > Spelling & Grammar > Set Proofing Language. In OneNote for the web this is found on the Home tab.

On the Review tab, click Editor > Set Proofing Language

Things to know

  • This change will only take affect from this point in the document forward.

  • To apply this change to any existing text in the document, press CTRL+A to select all of the existing text, then set the proofing language with the steps above.

  • This change only affects the current document. For subsequent documents you'll need to repeat these steps.

See Also

Check spelling and grammar in a different language

What languages are supported in Office?

Translate text into a different language

Remove languages and fonts you don't use

Right-to-left language features

Get support
Contact us
Expand your Office skills
Explore training

Was this information helpful?

Thank you for your feedback!

Thank you for your feedback! It sounds like it might be helpful to connect you to one of our Office support agents.

×