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Symptoms

Consider the following scenario. You have a Windows 7-based or Windows Server 2008 R2-based computer that has hotfix KB 2528984 installed. When you connect a new USB HUB device or a device that has a USB Hub built in, you receive the following message in a balloon:

Device driver software was not successfully installed You receive this message after you see "Currently installing." 

When you click the balloon, you see that the USB Hub device driver software installation failed together with the following message:

The device is not connected. However, even after you receive these error messages, the USB Hub Device works correctly.

For more information about KB2528984, click the following number to view the article in the Microsoft Knowledge Base:

2528984 Functionality issues on USB devices that are connected to a Windows 7-based computer that has an Intel platform.

Cause

This issue occurs because the hotfix for KB2528984 did not include the new Usb.inf file. This caused the USB Hub devices to start up slower than the device installation process.

Resolution

As of November 17, 2011, the hotfix for KB2528984 has been updated to resolve this issue. Please reinstall the hotfix if you experience the issue that is described in the "Symptoms" section.

Note You do not have to uninstall the older version of this hotfix before you reinstall the hotfix.



To check the file versions of the USB drivers that are installed on your computer, follow these steps:

  1. Use Windows Explorer to locate the %WINDIR%\System32\Drivers folder.

  2. Right-click Usbehci.sys, and then click Properties.

  3. Click the Details tab, and then check the value of the File version property.

  4. You can determine whether you have the earlier version of the hotfix installed if the File version value matches one of the following values:

    • 6.1.7600.16791

    • 6.1.7600.20940

    • 6.1.7601.17591

    • 6.1.7601.21700

  5. Repeat step 1 through step 4 for Usbhub.sys and for Usbport.sys.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.



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