When you click Test Access in the Microsoft Dynamics CRM E-mail Router, you receive the following error if you are using Microsoft Exchange 2010: 

The account does not have permissions to impersonate the requested user.


Impersonation is not set up on the account that you specified on the Incoming E-mail Profile or for the user who is set up to use the Router for incoming email.


You can specify Setup Exchange Impersonation for the account that is specified on the incoming profile if you are using a forward mailbox and for individual user accounts if theE-mail access type-Incoming is set to Router on the user record. To do this, follow these steps:

  1. Open the Microsoft Dynamics CRM E-mail Router Configuration Manager.

  2. Click the Configuration Profiles tab.

  3. Open the profile that has Incoming set for the direction, and then note the account that is specified in theAccess Credentials field.

  4. Set up Exchange Impersonation for the account that is specified in step 3. To do this, follow the steps in the following article: http://msdn.microsoft.com/en-us/library/bb204095.aspx

  5. Open Microsoft Dynamics CRM.

  6. Click Settings, and then click Users.

  7. Double-click a user record, and then note the value in the E-mail access type-Incoming field.

  8. If E-mail access type-Incoming is set to Router, you must use the information in the following article to set up Exchange Impersonation for the account that is listed in theDomain Name field:  http://msdn.microsoft.com/en-us/library/bb204095.aspx

  9. Complete steps 7 through 8 for all users who receive this error.


If you have specific questions or concerns while you are setting up impersonation, please contact your Exchange Administrator, or contact the Microsoft Exchange Support Team.

More Information

Need more help?

Expand your skills
Explore Training
Get new features first
Join Microsoft Insiders

Was this information helpful?

What affected your experience?

Thank you for your feedback!