When you click the Dynamics 365 app in Outlook (anywhere the app is supported), you see the following message:

“Your browser is currently unsupported.”

Symptoms

You are using a browser that is currently unsupported by the Dynamics 365 App for Outlook. 

Cause

To view a list of supported browsers, click here.

Resolution

Need more help?

Expand your skills
Explore Training
Get new features first
Join Microsoft Insiders

Was this information helpful?

What affected your experience?

Thank you for your feedback!

×