A privilege error occurs when attempting to use Dynamics 365 App for Outlook

Symptom

When attempting to use Dynamics 365 App for Outlook, you encounter an error referencing a missing privileg such as the following error:

"You don't have required privilege (prvReadOrganization), which limits certain functionality. Please contact your administrator to get necessary access."

Cause

This error will appear if the user associated with the mailbox record does not have sufficient privileges to use Dynamics 365 App for Outlook.

Resolution

Option 1: Assign Dynamics 365 App for Outlook User security role

A standard role exists to provide the privileges required to use Dynamics 365 App for Outlook. This role is named Dynamics 365 App for Outlook User and can be assigned to users who need to use App for Outlook. For more information on this role, see Provide security role access.

Option 2: Custom Role

If you prefer to customize a role to include the required privileges, refer to the More Information section for a list of privileges required to use Dynamics 365 App for Outlook.

More Information

The following table lists privileges required to use Dynamics 365 App for Outlook and the tab in a security role where the privilege can be found. A user with the System Administrator role can locate and modify a security role by navigating to Settings, Security, Security Roles. To view which role(s) are assigned to a specific user, navigate to Settings, click Security, click Users, select the specific User record, and then click Manage Roles. 

Privilege name

Entity

Location (tab) within security role

prvReadEmailServerProfile

EmailServerProfile

Business Management

prvReadRole

Security Role

Business Management

prvReadUser

User

Business Management

prvWriteMailbox

Mailbox

Business Management

prvReadMailbox

Mailbox

Business Management

prvReadOrganization

Organization

Business Management

prvSyncToOutlook (exchangesyncidmapping

Sync to Outlook

Business Management --> Privacy-related privileges

prvUseOfficeApps

Use Dynamics 365 App for Outlook

Business Management --> Privacy-related privileges

prvAppendToAccount

Account

Core Records

prvReadAccount

Account

Core Records

prvDeleteActivity

Activity

Core Records

prvAppendActivity

Activity

Core Records

prvWriteActivity

Activity

Core Records

prvCreateActivity

Activity

Core Records

prvReadActivity

Activity

Core Records

prvAppendToActivity

Activity

Core Records

prvShareActivity

Activity

Core Records

prvAppendToContact

Contact

Core Records

prvReadContact

Contact

Core Records

prvCreateContact

Contact

Core Records

prvReadUserQuery

Saved View

Core Records

prvReadAppModule

Model-driven App

Customization

prvReadAttribute

Field

Customization

prvReadEntity

Entity

Customization

prvReadRelationship

Relationship

Customization

prvReadSystemApplicationMetadata

System Application Metadata

Customization

prvReadSystemForm

System Form

Customization

prvReadUserApplicationMetadata

User Application Metadata

Customization

prvReadQuery

View

Customization

prvReadWebResource

Web Resource

Customization

prvSearchAvailability

Search Availability

Service Management --> Miscellaneous Privileges

 

The following table lists additional privileges which are required to view some of the default views used inside the Dynamics 365 App for Outlook forms. Without these privileges, a user may see the following error instead of the expected view (subgrid) of records:

"You do not have permission to access these records. Contact your Microsoft Dynamics 365 administrator for help."

Privilege name

Entity

Location (tab) within security role

prvReadIncident

Case

Service

prvReadOpportunity

Opportunity

Core Records

prvReadCompetitor

Competitor

Sales

prvReadConnection

Connection

Core Records

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