Cannot interact with desktop application without error message

Symptom

  1. Mouse clicks or keystrokes are not sent to the target application, without an error message.

  2. Desktop recorder does not recognize the elements of the desktop application.

Verifying issue

Open the PAD Designer and try to interact with the desktop application with one of the following actions:

  • Send keys

  • Send mouse click

  • Move mouse to image

Additionally, open the Desktop recorder and try to capture an element within the application.

Both the above operations cannot be performed without any error message.

Cause

The application runs with more elevated privileges than Power Automate Desktop.

Resolution

Both the application and PAD should run with the same privileges.

Power Automate Desktop does not run elevated by default. Hence, uncheck the "Run this program as an administrator" checkbox in the Compatibility section of the application's Properties window.

Another option would be to set PAD to run as admin as well.

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