Compatibility with Microsoft Dynamics CRM 2011

Introduction

This article focuses on recent and upcoming compatibility testing for Microsoft Dynamics CRM 2011. It also focuses on the most common compatibility questions that are processed by Microsoft Dynamics Technical Support. This article does not indicate Microsoft Dynamics CRM compatibility for all products. This article supplements the information in the Microsoft Dynamics CRM Implementation Guide.

More Information

The products that have a status of "TBD" are being considered for future compatibility. When the testing of these products is complete, this article will be updated to show the revised status values.

Microsoft Dynamics CRM 2011

The following list of products have been tested or are currently being tested for compatibility with Dynamics CRM 2011. The Minimum CRM version and CRM build number fields list the minimum Microsoft Dynamics CRM version that has been tested and is compatible with the listed product.

Product

Minimum CRM version

CRM build number

Status

.Net Framework 4.0

RTM

5.0.9688.583

Compatible

.Net Framework 4.0 PU3

-

-

TBD

.Net Framework 4.5

Update Rollup 8

5.0.9690.2243

Compatible

.Net Framework 4.5.1

Update Rollup 15

5.0.9690.3731

Compatible

.Net Framework 4.5.2

Update Rollup 17

5.0.9690.4150

Compatible

.Net Framework 4.6

-

-

Not Compatible

Active Directory Federation Services in Windows Server 2008 (AD FS 2.0)

RTM

5.0.9688.583

Compatible

Active Directory Federation Services in Windows Server 2008 R2

RTM

5.0.9688.583

Compatible

Active Directory Federation Services in Windows Server 2012

Update Rollup 13

5.0.9690.3432

Compatible

Active Directory Federation Services in Windows Server 2012 R2

-

-

Not compatible

Azure virtual machines (support for Microsoft Azure virtual machines)

-

-

Not compatible

Exchange Online (O365)

Update Rollup 5

5.0.9688.1533

Compatible

Exchange Online (BPOS)

RTM

5.0.9688.583

Compatible

Exchange Server 2000

-

-

Not compatible

Exchange Server 2003 SP2

RTM

5.0.9688.583

Compatible

Exchange Server 2003 SP3

RTM

5.0.9688.583

Compatible

Exchange Server 2007

RTM

5.0.9688.583

Compatible

Exchange Server 2010

RTM

5.0.9688.583

Compatible

Exchange Server 2010 SP1

Update Rollup 12

5.0.9690.3236

Compatible

Exchange Server 2010 SP2

Update Rollup 12

5.0.9690.3236

Compatible

Exchange Server 2010 SP3

Update Rollup 13

5.0.9690.3448

Compatible

Exchange Server 2013

Update Rollup 15

5.0.9690.3731

Compatible

Exchange Server 2013 SP1

Update Rollup 18

5.0.9690.4376

Compatible

Firefox

Update Rollup 12

5.0.9690.3236

Compatible

Google Chrome

Update Rollup 12

5.0.9690.3236

Compatible

Internet Explorer 6 (no longer supported)

-

-

Not compatible

Internet Explorer 7 (no longer supported)

RTM

5.0.9688.583

Compatible

Internet Explorer 8 (no longer supported)

RTM

5.0.9688.583

Compatible

Internet Explorer 9 (no longer supported)

RTM

5.0.9688.583

Compatible

Internet Explorer 10 (no longer supported)

Update Rollup 10

5.0.9688.2730

Compatible

Internet Explorer 11

Update Rollup 17

5.0.9690.4150

Compatible

Microsoft Application Virtualization (App-V) 4.6

-

-

Not compatible

Microsoft Office Communications Server 2007

RTM

5.0.9688.583

Compatible

Microsoft Office Communications Server 2007 R2

RTM

5.0.9688.583

Compatible

Microsoft Report Viewer 2010

RTM

5.0.9688.583

Compatible

Microsoft SharePoint 2010 (all editions)

RTM

5.0.9688.583

Compatible

Microsoft SharePoint 2013

Update Rollup 12

5.0.9690.3236

Compatible

Microsoft Office SharePoint Server 2007

RTM

5.0.9688.583

Compatible

Microsoft Visual C++ Redistributable 2008

RTM

5.0.9688.583

Compatible

Microsoft Visual C++ Redistributable 2010

Update Rollup 6

5.0.9690.1992

Compatible

Microsoft Windows Installer (MSI) 4.5

RTM

5.0.9688.583

Compatible

MSXML 4.0

RTM

5.0.9688.583

Compatible

Office 2003 SP3 (no longer supported)

RTM

5.0.9688.583

Compatible

Office 2007 SP2 (Cached-Exchange Mode Only)

RTM

5.0.9688.583

Compatible

Office 2007 SP3 (Cached-Exchange Mode Only)

Update Rollup 5

5.0.9688.1533

Compatible

Office 2010 (Cached-Exchange Mode Only)

RTM

5.0.9688.583

Compatible

Office 2010 SP1 (Cached-Exchange Mode Only)

RTM

5.0.9688.583

Compatible

Office 2010 SP2 (Cached-Exchange Mode Only)

Update Rollup 15

5.0.9690.3731

Compatible

Office 2013 MSI (Cached-Exchange Mode Only)

Update Rollup 10

5.0.9688.2730

Compatible

Office 2013 C2R (stand-lone) (Cached-Exchange Mode Only)

Update Rollup 10

5.0.9688.2730

Compatible

Office 2013 C2R (side-by-side with Office 2010)(Cached-Exchange Mode Only)

Update Rollup 10

5.0.9688.2730

Compatible

Office 2013 SP1 (Cached-Exchange Mode Only)

Update Rollup 17

5.0.9690.4150

Compatible

Office 2016 (MSI install only) (Cached-Exchange Mode Only)

Update Rollup 18

5.0.9690.4376

Compatible

Safari

Update Rollup 12

5.0.9690.3236

Compatible

SharePoint 2013

Update Rollup 12

5.0.9690.3236

Compatible

Small Business Server 2008 Premium (x64)

RTM

5.0.9688.583

Compatible

Small Business Server 2008 Standard (x64)

RTM

5.0.9688.583

Compatible

Small Business Server 2008 Standard

RTM

5.0.9688.583

Compatible

Small Business Server 2011 Essentials

Update Rollup 3

5.0.9688.1244

Compatible

SQL Server 2000

-

-

Not Compatible

SQL Server 2005

-

-

Not compatible

SQL Server 2008 Express Edition SP1

RTM

5.0.9688.583

Compatible

SQL Server 2008 Standard SP1 (x64)

RTM

5.0.9688.583

Compatible

SQL Server 2008 SP2 (x64)

Update Rollup 8

5.0.9690.2243

Compatible

SQL Server 2008 SP3 (x64)

Update Rollup 8

5.0.9690.2243

Compatible

SQL Server 2008 R2 (x64)

RTM

5.0.9688.583

Compatible

SQL Server 2008 R2 SP1 (x64)

Update Rollup 8

5.0.9690.2243

Compatible

SQL Server 2008 R2 SP2 (x64)

Update Rollup 8

5.0.9690.2243

Compatible

SQL Server 2008 R2 SP2 (CTP) (x64)

Update Rollup 8

5.0.9690.2243

Compatible

SQL Server 2008 R2 SP3

Update Rollup 18

5.0.9690.4376

Compatible

SQL Server 2008 Reporting Services (pre-Update Rollup 17)

RTM

5.0.9688.583

Compatible

SQL Server 2008 Reporting Services (post-Update Rollup 17)

-

-

Not Compatible

SQL Server 2008 R2 Reporting Services

RTM

5.0.9688.583

Compatible

SQL Server Compact 3.5 SP2

RTM

5.0.9688.583

Compatible

SQL Server Compact 4.0

Update Rollup 4

5.0.9688.1450

Compatible

SQL Server Active/Active Cluster**

Update Rollup 1

5.0.9688.1045

Compatible

SQL Server 2012****

Update Rollup 6

5.0.9690.1992

Compatible

SQL Server 2012 SP1

Update Rollup 10

5.0.9688.2730

Compatible

SQL Server 2014

-

-

Not Compatible

Windows 7 (32bit and 64bit)

RTM

5.0.9688.583

Compatible

Windows 7 SP1

RTM

5.0.9688.583

Compatible

Windows 8 (requires manual WIF enablement)

Update Rollup 10

5.0.9688.2730

Compatible

Windows 8.1

Update Rollup 17

5.0.9690.4150

Compatible

Windows 10

Update Rollup 17

5.0.9690.4150

Compatible

Windows RT

-

-

Not compatible

Windows Server 2003

-

-

Not compatible

Windows Server 2008 Standard SP2 (x64)

RTM

5.0.9688.583

Compatible

Windows Server 2008 Standard R2

RTM

5.0.9688.583

Compatible

Windows Server 2008 Enterprise SP2 (x64)

RTM

5.0.9688.583

Compatible

Windows Server 2008 Enterprise R2

RTM

5.0.9688.583

Compatible

Windows Server 2008 Datacenter SP2 (x64)

RTM

5.0.9688.583

Compatible

Windows Server 2008 Datacenter R2

RTM

5.0.9688.583

Compatible

Windows Web Server 2008 SP2 (x64) (front-end role only)

RTM

5.0.9688.583

Compatible

Windows Web Server 2008 R2 (front-end role only)

RTM

5.0.9688.583

Compatible

Windows Server 2012 Datacenter or Standard

Update Rollup 13

5.0.9690.3432

Compatible

Windows Server 2012 R2 Datacenter or Standard

-

-

Not compatible

Windows Web Server 2008 SP2 (x64) (front-end role only)

RTM

5.0.9688.583

Compatible

Windows Web Server 2008 R2 (front-end role only)

RTM

5.0.9688.583

Compatible

Windows Vista (x86 and x64)

RTM

5.0.9688.583

Compatible

Windows XP SP3 (no longer supported)

RTM

5.0.9688.583

Compatible


** Active/Active Clustering is supported, but not as a load-balancing configuration.

For a list of support web browsers with Microsoft Dynamics CRM 2011, please see the following link:

Browser compatibility with Microsoft Dynamics CRM 2011

Notes

  • 32-bit versions of Microsoft SQL Server and SQL Server Reporting Services (SSRS) are not supported.

  • Windows Server 2008 installed by using the Server Core installation option is not supported for installing and running Microsoft Dynamics CRM Server 2011.

  • Microsoft SQL Server 2008 Workgroup and Web, Compact, and Express editions of Microsoft SQL Server 2008 are not supported for running Microsoft Dynamics CRM Server 2011.

  • Windows Server 2008 for Itanium-based systems is not supported for installing and running Microsoft Dynamics CRM 2011

  • The CRM for Outlook client does not support Outlook configured in Online for tracking or synchronization (non-Cached Exchange mode)



For more information about System Requirements, see the System Requirements and Required Components topic in the Microsoft Dynamics CRM 2011 Implementation Guide.

Need more help?

Expand your skills
Explore Training
Get new features first
Join Microsoft Insiders

Was this information helpful?

Thank you for your feedback!

Thank you for your feedback! It sounds like it might be helpful to connect you to one of our Office support agents.

×