SYMPTOMS
When you try to use eConnect to pass in a transactional document, eConnect for Microsoft Dynamics GP logs the following error message:
Error Number = 3761
"Record already exists, cannot insert"
This problem occurs if multidimensional analysis (MDA) is not registered.
CAUSE
This problem occurs because MDA data exists in the company database. This can occur when the Registration window is used to turn off MDA after transactions have already been created that contain MDA records.
RESOLUTION
To resolve this problem, follow these steps:
1. |
Make a backup of the company database. |
2. |
Start the Support Administrator Console, Microsoft SQL Query Analyzer, or Microsoft SQL Server Management Studio. To do this, use one of the following methods, depending on the program that you are using. • SQL Server Desktop Engine (also known as MSDE 2000): Start the Support Administrator Console. To do this, click Start , click All Programs , click Microsoft Administrator Console , and then click Support Administrator Console . |
3. |
Run the following SQL statements against the company database: delete DTA00100 delete DTA00200 delete DTA00300 delete DTA00301 delete DTA00700 delete DTA10100 delete DTA10200 |