You receive the error message "Input string was not in a correct format."  in the following scenarios

Scenario 1

When you run an integration in Integration Manager for Microsoft Dynamics GP that uses the eConnect Destination adapters.

Scenario 2 

When you do not have sufficient permissions on the machine running the integration


Scenario 1

This error occurs after you upgrade to Integration Manager for Microsoft Dynamics GP 2010 or for Microsoft Dynamics GP 10.0 from an earlier version and the Shift Decimal Point property on a numeric field did not upgrade correctly and leaves the value blank.  This can occur on any integration that uses an eConnect destination adapter that contains a numeric field that has the Shift Decimal Point property.  For example the Debit Amount,Credit Amount or Quantity fields.

Scenario 2

When you install Integration Manager, you did not install as an Administrator and run the first integration.  This allows the required .xml files to get created on the machine.


Scenario 1

To resolve this problem, open the Destination Mapping window and check the Debit Amount, Credit Amount and Quantity fields for the destination adapter that you are using.  Select one field at a time and look in the properties window in the lower-left corner of the Destination Mapping window.  Make sure that the Shift Decimal Point property is not blank.  In most cases the value for this property is zero ('0').  If you find a field where this property is blank, type a zero and then save the integration.

Scenario 2

To resolve this problem, log into the machine as Administrator and run the integration.  Once the integration is run the first time, you can run integrations as another user.  The user must have full control to the following registry keys:

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk. 

1. Click Start, click Run, type Regedt32 in the Open dialog box, and then click OK. This will open Registry Editor.

2. The four registry keys that must have the security changed are:


HKEY_CLASSES_ROOT\ Wow6432Node\TypeLib

3. Select one of the folders listed in step 2, click Security from the menu and then click Permissions.

4. Make sure the user groups that use Integration Manager have Read and Full Control marked.

5. Repeat steps 3 and 4 for all four registry entries listed in step 2.

Need more help?

Expand your skills
Explore Training
Get new features first
Join Microsoft Insiders

Was this information helpful?

What affected your experience?

Thank you for your feedback!