GetReportOptions failed in Report Scheduler in Microsoft Business Solutions - Business Portal together with Microsoft Dynamics SL

This article provides a solution to an error that occurs when you enter Report Scheduler in Microsoft Business Solutions - Business Portal together with Microsoft Dynamics SL.

Applies to:   Microsoft Dynamics SL
Original KB number:   912091

Symptoms

When you enter Report Scheduler in Microsoft Business Solutions - Business Portal together with Microsoft Dynamics SL, you may receive the following error message:

GetReportOptions failed. Error info= <soap:Server : System.Web.Services.Protocols.SoapExcpetion: Server was unable to process request. ---> System.NullReferenceExcpetion: Object reference not set to an instance of an object.

Cause

The Microsoft Solomon client isn't installed on the server that is running Business Portal.

Resolution

To install the Microsoft Solomon client on the server that is running Business Portal, follow these steps:

  1. Map a drive to the server that is running Microsoft Solomon:

    1. In Windows Explorer, select Map Network Drive on the Tools menu.

    2. In the Drive list, select a drive letter.

    3. In the Folder box, type the path for the Solomon folder on the server that is running Microsoft Solomon.

      Note

      By default, the Solomon folder is located at \\SolomonServerName\ProgramFiles\Solomon. In this example, SolomonServerName stands for name of the server that is running Microsoft Solomon.

  2. In the Solomon folder, open the Wrkstn folder.

  3. Run the Setup.exe file that is in the Wrkstn folder.