You may receive the following error message intermittently when you use eConnect for Dynamics GP 2010 or the eConnect destination adapter in Integration Manager:

There was an error writing to the pipe: The pipe is being closed.

Symptoms

The eConnect for Microsoft Dynamics GP 2010 Integration Service is a WCF service. A connection can remain inactive, during which no application messages are received, before it is dropped after 10 minutes. This is by default.

Cause

Add receiveTimeout="infinite" to the Microsoft.Dynamics.GP.eConnect.Service.exe.config file for the eConnect Integration service. The binding section should resemble this:

<binding name="eConnectNamedPipeConfig" closeTimeout="00:10:00" sendTimeout="00:10:00" receiveTimeout ="infinite" transferMode="Buffered" hostNameComparisonMode="StrongWildcard" maxBufferPoolSize="2147483647" maxBufferSize="2147483647" maxReceivedMessageSize="2147483647"><readerQuotas maxDepth="60" maxStringContentLength="2147483647"maxArrayLength="2147483647" maxBytesPerRead="2147483647" maxNameTableCharCount="2147483647" /><security mode="Transport"><transport protectionLevel="EncryptAndSign" /></security>
</binding>

Resolution

The Binding.ReceiveTimeout property is described in MSDN at the following link:

http://msdn.microsoft.com/en-us/library/system.servicemodel.channels.binding.receivetimeout.aspx

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