Error message when you integrate a sales transaction in Integration Manager in Microsoft Dynamics GP: "Quantities for item '[Item Number]' must be allocated before they can be fulfilled"

Symptoms

When you integrate a sales transaction in Integration Manager in Microsoft Dynamics GP or in Microsoft Business Solutions - Great Plains 8.0, you receive the following error message:

DOC 1 ERROR: Quantities for item 'Item Number' must be allocated before they can be fulfilled.

Cause

This problem occurs if one or more of the following conditions are true:

  • The invoice ID or the order ID that you want to integrate is configured to allocate by using the Document/Batch option.

  • The invoice ID or the order ID that you want to integrate is configured to use a separate fulfillment process.

  • The Sales Order Processing Setup Options window is configured to use the Auto Assign Lot Numbers option.

Resolution

To resolve this problem, obtain the latest service pack for Integration Manager. To obtain Integration Manager 8.0 for Microsoft Great Plains 8.0, visit the following Microsoft Web site:

https://mbs.microsoft.com/customersource/support/downloads/servicepacks/IntegrationManager8.0.htmTo obtain Integration Manager 9.0 for Microsoft Dynamics GP 9.0, visit the following Microsoft Web site:

https://mbs.microsoft.com/customersource/support/downloads/servicepacks/Integration+Manager+9.0+Downloads.htm To obtain Integration Manager 10.0 for Microsoft Dynamics GP 10.0, visit the following Microsoft Web site:

https://mbs.microsoft.com/customersource/support/downloads/servicepacks/integration_manager_10_downloads_for_microsoftdynamics10.htm?printpage=false

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Business Solutions - Great Plains 8.0 Integration Manager Service Pack 3.

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