Error message when you try to print a report in Microsoft Dynamics CRM 3.0: "Unable to load client print protocol"

When you try to print a report in Microsoft Dynamics CRM 3.0, you receive the following error message:

Unable to load client print protocol.

Symptoms

This problem may occur if the ActiveX components are not installed.

Cause

To resolve this problem, enable the ActiveX settings in Windows Internet Explorer. Then, add the following URLS to the Local Intranet zone:

  • The URL for the computer that is running the Microsoft Dynamics CRM server

  • The URL for the computer that is running Microsoft SQL Server Reporting Services

To do this, follow these steps:

  1. Start Windows Internet Explorer.

  2. On the Tools menu, click Internet Options.

  3. On the Security tab, click Local Intranet, and then click Sites

  4. Click Advanced.

  5. Type the URL for the computer that is running Microsoft Dynamics CRM server in the Add this website to the zone box, and then click Add.

  6. Type the URL for the computer that is running Microsoft SQL Server Reporting Services in the Add this website to the zone box, and then click Add.

  7. Click Close to close the Local Intranet dialog box, and then click OK.

  8. On the Security tab, click Custom Level.

  9. Click Enable for each component that is listed under ActiveX controls and plugins.

  10. Click OK to close the Internet Options dialog box.

  11. Exit Windows Internet Explorer, and then start Microsoft Dynamics CRM 3.0.

  12. Try printing the report.

    If you continue to experience the problem that is described in the "Symptoms" section, manually install the ActiveX components. To do this, follow these steps:

    1. Locate the Report Server\bin folder.

      Notes

      • If you run Microsoft SQL Server 2000 Reporting Services, the folder is located in the following location:

        C:\Program Files\Microsoft SQL Server\MSSQL\Reporting Services\ReportServer\bin

      • If you run Microsoft SQL Server 2005 Reporting Services, the folder is located in the following location:

        C:\Program Files\Microsoft SQL Server\MSSQL.4\Reporting Services\ReportServer\bin

    2. Right-click the RSClientPrint.cab file, and then click Extract. Extract the file to the folder in step 12a.

    3. Right-click the RSClientPrint.inf file that you extracted in step 12b, and then click Install.

    4. Try to print the report.

Resolution

SQL Server Reporting Services uses an ActiveX Print control to control the print functions in Windows Internet Explorer. If the ActiveX components are not installed on the computer that is running Microsoft Dynamics CRM 3.0, you receive the error message that is mentioned in the "Symptoms" section.

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