Error message when you try to search the item catalog in Order Management for Business Portal 3.0 together with Microsoft Dynamics GP 9.0: “The order cannot be processed at this time”

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Symptoms

When you try to search the item catalog in Order Management for Business Portal 3.0 together with Microsoft Dynamics GP 9.0, you receive the following error:

The order cannot be processed at this time. Please try again later.

Cause

This error occurs because an incompatible version of eConnect Runtime for Microsoft Dynamics GP 9.0 has been installed on the computer that is running Business Portal.

Order Management for Business Portal 3.0 depends on eConnect Runtime 9.0.0.0. However, Web Services for Microsoft Dynamics GP is currently compiled with Service Pack 1 for eConnect Runtime 9.0.1.0. If version 9.0.1.0 of eConnect Runtime is installed on the same computer on which Order Management for Business Portal 3.0 is installed, the error will occur.

Resolution

To resolve this problem, remove eConnect Runtime 9.0.1.0 from the computer. To do this, follow these steps:

  1. Click Start, and then click Control Panel.

  2. Double-click Add or Remove Programs.

  3. Select eConnect Runtime 9.0.1.0, and then click Remove.

After you remove eConnect Runtime 9.0.1.0, install eConnect Runtime 9.0.0.0 from the Business Portal installation CD. To run the installer, follow these steps:

  1. Locate the PreReqs\eConnect folder on the Business Portal installation CD.

  2. Double-click the Microsoft_Business_Solutions_eConnect_Runtime.exe file.

More Information

Steps to reproduce the problem

  1. Configure Order Management for Business Portal 3.0, and then create an order to confirm that the program is working.

  2. Remove eConnect Runtime 9.0.0.0 from the computer.

  3. Install Web Services for Microsoft Dynamics GP 9.0 on the computer.

  4. Try to create an order by using Order Management for Business Portal 3.0.

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