Symptoms
When you print a custom report or preview a custom report before you print it in Microsoft Dynamics SL, you receive the following error messages:
Crystal Print Engine Error: 536-Error in File. Unable to connect: incorrect log on parameters.
System Message 7014: Report Execution failed with error 536.
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Cause
Cause 1
The Trusted Connection parameter in the report file is set to 1. See Resolution 1.
Cause 2
The Open Database Connectivity (ODBC) connection on the workstation is corrupted. See Resolution 2.
Cause 3
The report is pointing to two different databases. See Resolution 3.
Cause 4
The E7F575915A2E4897A517779C0DD7CE login account in SQL Server 2005 or in SQL Server 2008 is disabled or has an incorrect password. See Resolution 4.
Resolution
Resolution 1
To resolve this problem, set the Trusted Connection parameter in the report file to 0 (zero). To do this, follow these steps:
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Start Crystal Reports 10 for Solomon.
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Click Open, select the custom report, and then click Open.
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On the Database menu, click Set Datasource Location.
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In the Set Datasource Location dialog box, expand Current Data Source: Properties.
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Under Current Data Source: Properties, locate the Trusted Connection: 1 parameter.
Note If the Trusted Connection parameter is not listed, the Trusted Connection option was not selected when the report was created, and this is not the cause of the error. -
Right-click Trusted Connection: 1, and then click Edit.
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Type 0.
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Click Close.
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Click Save.
Resolution 2
To resolve this problem, delete the Microsoft Dynamics SL ODBC connections. Then, let Microsoft Dynamics SL re-create the connections. To do this, follow these steps:
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Click Start, click Control Panel, click Administrative Tools, and then click Data Sources (ODBC).
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On the User DSN tab, remove any items that point to your Microsoft Dynamics SL application databases.
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On the System DSN tab, remove any items that point to your Microsoft Dynamics SL application databases.
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Rerun the report in Microsoft Dynamics SL. The ODBC connections are automatically re-created when you run a report in Microsoft Dynamics SL.
Resolution 3
To resolve this problem, reset the data source in Crystal Reports. To do this, follow these steps:
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Start Crystal Reports 10 for Solomon.
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Click Open, select the custom report, and then click Open.
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On the Database menu, click Set Datasource Location.
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In the Replace With box, expand Create New Connection, and then expand ODBC (RDO).
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Click your Microsoft Dynamics SL database, and then click Next.
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Enter your log on information. Do not select the Trusted Connection check box.
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Click Finish.
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Click the database in the Replace With box. Then, click the database in the Current Data Source box.
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Click Update.
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If you have multiple databases in the Current Data Source box, repeat steps 8 and 9 for each database.
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Click Save, and then exit Crystal Reports.
Resolution 4
To resolve this problem, enable the E7F575915A2E4897A517779C0DD7CE login account in SQL Server 2005 or in SQL Server 2008, and then run the Synchronize All Ownership & Security update scenario in the Database Maintenance (98.290.00) screen in Microsoft Dynamics SL. To do this, follow these steps:
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Start SQL Server Management Studio, and then connect to the server that hosts the Microsoft Dynamics SL databases.
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In the Object Explorer pane, expand Security, and then expand Logins.
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Under Logins, right-click E7F575915A2E4897A517779C0DD7CE, and then click Properties.
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In the Select a page pane, click Status, and then click Enabled under Login.
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Click OK, and then close SQL Server Management Studio.
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In Control Panel, click Administrative Tools, and then click Microsoft Dynamics SL Database Maintenance.
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Connect to the instance of SQL Server that is hosting the Microsoft Dynamics SL databases.
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Click the Update Database tab.
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In the Update Scenarios list, click Synchronize All Ownership & Security, and then click Update Database.
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At the bottom of the Database Maintenance (98.290.00) screen, confirm that the progress bar has finished, and then click Close.