Organization database updates fail during the import process of the organization in Microsoft Dynamics CRM 2011

Symptoms

Updates to the Microsoft Dynamics CRM 2011 organization database are applied as part of import organization process and/or update rollup installation process. Applying such database updates on the organization database may fail.

Error message reported in Dmsnap-in log for the database update failures:

Info| Applying slipstream dbUpdates to organization.  Id=3e118e13-8516-df11-b6c3-00155d40da1c, UniqueName=CRMtest.
Error| Applying database updates to organization with name = CRMtest Id=3e118e13-8516-df11-b6c3-00155d40da1c failed with Exception:
System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.AggregateException: One or more errors occurred. ---> Microsoft.Crm.BusinessEntities.CrmObjectNotFoundException: No rows could be found for Entity with id b5fa3433-7692-11e0-a0f5-1cc1de634cfe if Entity were published

Error reported in update rollup installation log:

Info| Database update install failed for orgId = a4c9a180-1216-dd11-be24-001e0bc83c12. Continuing with other orgs. Exception: System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.AggregateException: One or more errors occurred. ---> Microsoft.Crm.BusinessEntities.CrmObjectNotFoundException: No rows could be found for Entity with id b5fa3433-7692-11e0-a0f5-1cc1de634cfe if Entity were published

Note: GUIDs in the error messages above may differ from those shown, as the entities involved may vary

Cause

This issue occurs when the NumThreadsForIndexCreation registry value has been added to the registry

Resolution

To modify the registry, please follow the steps below:

1. Point to the Start Menu, click Run, and type regedit

2. Navigate to the following location in the registry: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM

3. Remove the NumThreadsForIndexCreation key

4. Reapply the update rollup or re-import the organization database depending on which process incurred failure

Need more help?

Expand your skills
Explore Training
Get new features first
Join Microsoft Insiders

Was this information helpful?

Thank you for your feedback!

Thank you for your feedback! It sounds like it might be helpful to connect you to one of our Office support agents.

×