PAD Console does not show any flows

Symptom

The Power Automate Desktop Console does not show any Desktop flows in the "My flows" list.

Verifying issue

  1. In the Power Automate Desktop Console, press the "Refresh" button to make sure that the Desktop flows are still not shown.

  2. Go to the Power Automate Portal and make sure that the Desktop flows do exist in the "My flows" > "Desktop flows" section.

  3. Make sure that the Proxy server is using automatic authentication with the user's Active Directory account (eg. Kerberos, Negotiate, NTLM).

  4. Make sure that you do not have to input your credentials each time you need to authenticate with the proxy server.

  5. Verify that the Proxy server in not a Socks Proxy Server.

Cause

The machine running Power Automate Desktop is using a proxy server that requires authentication. Power Automate does not authenticate with the proxy server on the communication with Power Automate, thus the communication fails. 

Resolution

Make sure you have administrator rights or someone who has such rights is available. 

Navigate to Power Automate Desktop installation folder ('C:\Program Files (x86)\Power Automate Desktop').

Backup these 2 files 'PAD.Designer.Host.exe.config' and 'PAD.Console.Host.exe.config' in order to recover them if something goes wrong. 

For both files do the following: 

Edit each file with administrator rights, and at the end of the root xml node (<configuration>), add the following child xml node

     <system.net>

          <defaultProxy enabled="true" useDefaultCredentials="true"> 

          </defaultProxy> 

     </system.net>

Save the file.

Restart Power Automate Desktop from the system tray icon (right-click on the PAD icon in the system tray and Exit). 

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