Windows Firewall might be preventing the adapter from connecting to your device. Here's how to allow the adapter to communicate through the firewall:

  1. In the search box on the taskbar, enter allow firewall, then select Allow an app through Windows Firewall from the list of results.

  2. Under Name, find Wireless Display, make sure Private and Public are selected, then select OK.

Note: If you can’t select anything in the Allowed apps and features box, you aren't logged in as an administrator. Select Change Settings, type your administrator password, and select Yes. If you're an administrator on your device, the password should be the same as the one you used to set up your device. Then, make sure Private and Public are selected and select OK.

Did that fix your problem? 

Need more help?

Expand your skills
Explore Training
Get new features first
Join Microsoft Insiders

Was this information helpful?

What affected your experience?

Any additional feedback? (Optional)

Thank you for your feedback!

×