When you create a company in Management Reporter, the Data Provider is not available in the Source System drop-down list.


Cause 1

Management Reporter is installed on Windows Server 2008 64-bit and the Enable 32-Bit Applications is set the True in the Application Pool. 

Cause 2

The Data Provider has not been installed.


Resolution 1

Check that the Enable 32-bit Applications option is set to False.

1. Open Internet Information Services (IIS) Manager.

2. Expand the server.

3. Click Application Pools.

4. Right-click Management Reporter and then click Advanced Settings.

5. Change Enable 32-Bit Applications from True to False.

6. Click OK.

7. Restart IIS.

Resolution 2

Check that the Data Provider is installed. By default, the provider will be installed at C:\Program Files\Microsoft Dynamics ERP\Management Reporter\2.0\Providers. The Provider folder will have a subfolder for the Data Provider that is installed. Within that folder, there will be a file that is named Microsoft.Dynamics.Performance.DataProvider.GeneralLedger.nn.dll, where nn is the name of the Dynamics ERP you have installed. If the Data Provider is not installed, you can download it from the link below.

Need more help?

Expand your skills
Explore Training
Get new features first
Join Microsoft Insiders

Was this information helpful?

What affected your experience?

Thank you for your feedback!