Symptoms
In Microsoft Business Solutions - Business Portal, when you click Project to open the Project center page, you receive the following error message in the Project Communicator Web part:
Error:
Connector:Connection time out.
HRESULT=0x800A1527 - Client:An unanticipated error occurred during the processing of this request.
HRESULT=0x800A1527 - Client:Sending the Soap message failed or no recognizable response was received
HRESULT=0x800A1527 - Client:Unspecified client error.
HRESULT=0x800A1527
faultcode=Client
faultstring=Connector:Connection time out.
faultactor=
detail=Connector:Connection time out.
HRESULT=0x800A1527 - Client:An unanticipated error occurred during the processing of this request.
HRESULT=0x800A1527 - Client:Sending the Soap message failed or no recognizable response was received
HRESULT=0x800A1527 - Client:Unspecified client error.
HRESULT=0x800A1527
Cause
This problem occurs because the Transmission Control Protocol (TCP) port that you specified for the top-level Web site in Microsoft Internet Information Services (IIS) Manager contains a value that is different from the value that you specified in the ProjectService.wsdl file.
Resolution
To resolve this problem, follow these steps:
-
In Internet Information Services (IIS) Manager, find the top-level Web site where you installed Microsoft Business Portal. To do this, follow these steps:
-
Click Start, point to Administrative Tools, and then click Internet Information Services (IIS) Manager.
-
In the Internet Information Services (IIS) Manager dialog box, expand Server_name.
Note In this article, Server_name represents the name of the server where you installed Microsoft Business Portal. -
Expand Web Sites.
-
-
Right-click the top-level Web site, and then click Properties.
-
Click the Web Site tab, note the value in the TCP port box, and then click Cancel.
-
Open the ProjectService.wsdl file in Notepad.
Note The default location for the ProjectService.wsdl file is Microsoft Business Solutions\Business Portal\Applications\PMA. -
Locate the following line near the end of the file:
<soap:address location="HTTP://Server_name:80/BusinessPortal/Applications/PMA/PCService.asmx" />
Note In this line, "Server_name" represents the name of the server where you installed Microsoft Business Portal.
-
Replace the port number with the value that you noted in step 3. The line in step 5 shows port 80.
-
On the File menu, click Save.
The issue that is described in the Symptoms section does not apply to Microsoft Dynamics SL 7.0.