Program crashes when you send an attachment through Outlook

Symptoms

Consider the following scenario:

  • You are running Microsoft Outlook 2010 version 14.0.7140.5001 or a later version.
  • You open a file in a program other than an Office application, and you send the file as an email attachment.

In this scenario, you may receive the following error message, and then the program crashes:



If you review the Application log, you find the following crash signature details:

Application Name: <varies>
Module Name: Msvcr90.dll
Module version: <varies>
Offset: 0x0003B4A8

Note In this same configuration, MFCMAPI.exe crashes when you try to open your mailbox by using the MFCMAPI tool. In that case, the crash signature details match those provided in the preceding sample, and the Application Name value is Mfcmapi.exe.


Cause

This behavior is triggered by a known issue that occurs when Outlook is connected to an Exchange Server 2013 mailbox through a MAPI over HTTP connection.


Resolution

To resolve this issue, apply the latest Outlook 2010 update: 

https://support.microsoft.com/en-us/kb/2625547/

Note This issue is resolved in the April 14, 2015 update for Outlook 2010 . You can install the April 14, 2015 update or a later update for Outlook 2010 to resolve this issue.


Workaround

If you cannot install the April 14, 2015 update or a later Outlook 2010 update at this time, you can temporarily work around this problem by using the following method.

To work around this issue, open a new email message in Outlook, and then add the attachment to it by following these steps:
  1. In the program that you used to opened the file that you want to send as an attachment, save the file to your hard disk.
  2. In Outlook 2010, click New E-mail.
  3. On the Message tab, click Attach File.
  4. Locate the file that you saved in step 1, select the file, and then click Insert.
  5. Address the email, enter the text that you want in the Subject line and body of the email, and then click Send.

More Information

To review the Application log, follow these steps:

  1. In Control Panel, open Administrative Tools.
  2. Double-click Event Viewer.
  3. In the navigation pane, select Application under Windows Logs.
  4. In the Actions pane, click Filter Current Log.
  5. In the Filter Current Log dialog box, enter 1000 in the box that contains <All Event IDs>, and then click OK.

To determine whether you are using a MAPI over HTTP connection, follow these steps:

  1. With Outlook running, press the CTRL key and right-click the Outlook icon on the taskbar.
  2. Click Connection Status.
  3. View the Proxy Server, Server name and Protocol columns.
  4. If you are using a MAPI over HTTP connection, the Proxy Server column is empty, the Server name column lists the actual server name, and Protocol column displays HTTP.



    Note
    If you are using an RPC over HTTP connection (Outlook Anywhere), the Proxy Server column contains the server name, the Server name column lists the GUID of the server, and the Protocol column displays RPC/HTTP.

For more information about MAPI over HTTP connections, go to the following Microsoft TechNet website:
Properties

Article ID: 3050312 - Last Review: 29 May 2015 - Revision: 1

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