Información acerca de la lista de Autocompletar de Outlook

Se aplica a: Outlook 2016Outlook 2013Microsoft Office Outlook 2003

Resumen


Este artículo contiene información general acerca de la lista de Autocompletar de Microsoft Outlook. Además de describir esta característica, este artículo contiene más información e instrucciones paso a paso para que los usuarios avanzados administren la lista.

Más información


Outlook mantiene la lista de Autocompletar. La lista se utiliza tanto en la característica de comprobación automática de nombres como en la de finalización automática. La lista de Autocompletar, también conocida como memoria caché de alias, se genera automáticamente cuando envía mensajes de correo electrónico desde Outlook. La lista contiene direcciones SMTP, entradas de LegacyExchangeDN y nombres para mostrar de personas a las que envió correos electrónicos anteriormente.

Nota La lista de Autocompletar para Outlook es específica de Outlook y no se comparte con Outlook Web App (OWA). OWA mantiene su propia lista de Autocompletar.

En las secciones siguientes, se proporciona información acerca de la característica Autocompletar.
 

Límite de cantidad de entradas

Outlook limita el número de entradas que puede guardar en la lista de Autocompletar. Tras alcanzar este límite, Outlook usa un algoritmo interno para determinar qué nombres deberían quitarse de la lista. Lo hace en función de una ponderación del uso. Por tanto, es posible que algunos nombres se quiten inesperadamente de su caché de alias. Hay dos enfoques generales que puede usar para evitar esta situación:
  1. Puede quitar proactivamente de la lista de Autocompletar las entradas que ya no necesite. Este es el enfoque preferido. Para obtener más información sobre cómo hacerlo, consulte la sección "Cómo quitar entradas de la lista de Autocompletar individualmente".
  2. Puede incrementar el límite de la caché de alias. Dado que esta configuración no está probada, no se recomienda. Si tiene una caché de alias grande, también podría perder un gran número de entradas almacenadas si la caché se daña y no puede usarse. Para obtener más información sobre cómo aumentar el límite, consulte la sección "Cómo cambiar el límite de la lista de Autocompletar".
Los límites son los siguientes:
  • Outlook 2016: 1000 entradas
  • Outlook 2013: 1000 entradas
  • Outlook 2010: 1000 entradas
  • Outlook 2007: 2000 entradas
  • Outlook 2003: 1000 entradas
 

Cómo habilitar la característica Autocompletar

En esta sección se explica detalladamente cómo habilitar o deshabilitar la característica Autocompletar.
Outlook 2010, Outlook 2013 y Outlook 2016
Para obtener acceso a la configuración de Autocompletar, siga estos pasos: 
  1. En el menú Archivo, haga clic en Opciones.
  2. Seleccione la pestaña Correo.
  3. Desplácese hasta, aproximadamente, la mitad, hasta que vea Enviar mensajes. Asegúrese de que la casilla Usar lista de Autocompletar para sugerir nombres al escribir en las líneas Para, CC y CCO esté activada.

    Ventana Enviar mensajes; la casilla Usar la lista de Autocompletar para sugerir nombres al escribir en las líneas Para, CC y CCO activada
Outlook 2003 y Outlook 2007
Para obtener acceso a la configuración de Autocompletar, siga estos pasos:
  1. Haga clic en Herramientas y, a continuación, en Opciones.
  2. Haga clic en el botón Opciones de correo electrónico.
  3. Haga clic en el botón Opciones de correo electrónico avanzadas.
  4. Asegúrese de que la casilla Sugerir nombres al completar los campos Para, Cc y Cco esté activada. (A continuación, se muestra una captura de pantalla de este paso).

    Ventana Opciones de correo avanzadas, la casilla Sugerir nombres al completar los campos Para, CC y CCO activada
 

Cómo importar archivos .nk2 a Outlook 2010, Outlook 2013 y Outlook 2016

Microsoft Office Outlook 2007 y las versiones anteriores almacenan la lista de Autocompletar en un archivo de alias (.nk2) del disco. Outlook 2010, Outlook 2013 y Outlook 2016 almacenan la lista de Autocompletar como un mensaje oculto en el almacén de mensajes principal. Outlook 2010, Outlook 2013 y Outlook 2016 le permiten importar los antiguos archivos .nk2.

Para obtener más información sobre cómo importar archivos .nk2 en Outlook 2010, visite el siguiente sitio web de Microsoft:

Cómo copiar la lista de Autocompletar

Los pasos para exportar e importar la lista de Autocompletar son diferentes dependiendo de la versión de Outlook que use.
Outlook 2010, Outlook 2013 y Outlook 2016
Para copiar la lista de Autocompletar de Outlook 2010, Outlook 2013 y Outlook 2016, siga estos pasos:

Paso 1.

Para exportar el mensaje del buzón de Autocompletar, siga estos pasos:
  1. Cierre Outlook y, a continuación, cierre Outlook Web Access u Outlook Web App (OWA) en todas las estaciones de trabajo conectadas a su buzón.
  2. Descargue e instale MFCMAPI desde https://github.com/stephenegriffin/mfcmapi.
  3. Ejecute mfcmapi.exe.
  4. En el menú Sesión, haga clic en Conexión.
  5. Si se le pide que elija un perfil, seleccione el nombre del perfil deseado y haga clic en Aceptar.
  6. En el panel superior, localice la línea que corresponde a su buzón y, a continuación, haga doble clic en ella.
  7. En el panel de navegación izquierdo, expanda Root Container (Contenedor raíz) y, a continuación, expanda Principio del almacén de información o IPM_SUBTREE.
  8. Haga clic con el botón derecho en la carpeta Bandeja de entrada y, a continuación, haga clic en Abrir tabla de contenido asociada. Esta acción abre una ventana nueva de MFCMAPI que contiene varias propiedades.
  9. En la columna Asunto, haga clic con el botón derecho en el elemento con el asunto IPM.Configuration.Autocomplete y, a continuación, haga clic en Export Message (Exportar mensaje). Esta acción abre la ventana Save Message To File (Guardar el mensaje en archivo).
  10. En la lista desplegable, seleccione MSG file (UNICODE) [Archivo MSG (UNICODE)] y, a continuación, haga clic en Aceptar.
  11. Seleccione la ubicación de la carpeta en la que quiera guardar el mensaje y haga clic en Guardar. Anote esta ubicación.
Paso 2

Para importar el mensaje del buzón de Autocompletar, siga estos pasos:
  1. Cierre Outlook y, a continuación, cierre Outlook Web Access u Outlook Web App (OWA) en todas las estaciones de trabajo conectadas a su buzón.
  2. Descargue e instale MFCMAPI desde https://github.com/stephenegriffin/mfcmapi.
  3. Ejecute mfcmapi.exe.
  4. En el menú Sesión, haga clic en Conexión.
  5. Si se le pide que elija un perfil, seleccione el nombre del perfil deseado y haga clic en Aceptar.
  6. En el panel superior, localice la línea que corresponde a su buzón y, a continuación, haga doble clic en ella.
  7. En el panel de navegación izquierdo, expanda Raíz - Buzón y, a continuación, expanda Principio del almacén de información o IPM_SUBTREE.
  8. Haga clic con el botón derecho en la carpeta Bandeja de entrada y, a continuación, haga clic en Abrir tabla de contenido asociada. Esta acción abre una ventana nueva de MFCMAPI que contiene varias propiedades.
  9. Para evitar entradas duplicadas, tiene que eliminar el mensaje de Autocompletar existente.

    Nota: Antes de eliminar el mensaje PM.Configuration.Autocomplete, tiene que exportarlo. Para ello, siga los pasos de la sección "Cómo exportar la caché de Autocompletar".

    Para eliminar el mensaje de Autocompletar existente, siga estos pasos:
     
    1. En la columna Asunto, localice el elemento que tiene el asunto IPM.Configuration.Autocomplete.
    2. Haga clic con el botón derecho en el elemento y, luego, haga clic en Eliminar mensaje. Esto abre la ventana Eliminar elemento.
    3. En la lista desplegable, seleccione Permanent deletion (deletes to deleted item retention if supported) [Eliminación permanente (las eliminaciones se encuentran en la retención de elementos, si se admite)] y, a continuación, haga clic en Aceptar.
  10. En el menú Carpeta, haga clic en Importar y, a continuación, en From MSG (Desde mensaje).
  11. Localice el archivo .msg que creó en el paso 11 de la sección "Cómo exportar la lista de Autocompletar" y, a continuación, haga clic en Aceptar.
  12. En la ventana Load MSG (Cargar mensaje) que aparece, seleccione Load message into current folder (Cargar mensaje en la carpeta actual) en la lista Load style (Estilo de carga) y, a continuación, haga clic en Aceptar.
La información de Autocompletar se importa desde el archivo IPM.Configuration.Autocomplete_<código hexadecimal>.msg, donde el marcador de posición <código hexadecimal> representa una cadena larga de números y letras.
Outlook 2003 y Outlook 2007

Los pasos para copiar la lista de Autocompletar de Outlook 2003 y Outlook 2007 son diferentes. Eso se debe a que Outlook 2003 y Outlook 2007 almacenan la lista de Autocompletar en el archivo .nk2.

Para copiar la lista de Autocompletar en Outlook 2007, vaya al siguiente sitio web de Microsoft:

Copiar la lista de Autocompletar a otro equipo

Cómo quitar entradas de la lista de Autocompletar individualmente

Para quitar entradas de la caché de Autocompletar individualmente, siga estos pasos:
  1. Abra un nuevo mensaje de correo electrónico.
  2. Escriba los primeros caracteres de la entrada de Autocompletar que quiera quitar.
  3. Cuando aparezca la entrada en la lista de sugerencias, pase el puntero del ratón sobre el nombre hasta que aparezca resaltado, pero no haga clic en él.
  4. Cuando aparezca el icono "X" junto a la sugerencia resaltada, haga clic en X para quitar la entrada de la lista o presione la tecla Supr en el teclado. 

Al seleccionar la X, impedirá que esa entrada (nombre) aparezca de nuevo en la lista Autocompletar, pero no la eliminará de la cuenta. La entrada puede seguir apareciendo en otras áreas de Outlook (como los cuadros de búsqueda).

Nota: Si envía a una persona un nuevo correo electrónico después de eliminar su nombre de la lista Autocompletar, su información se agregará de nuevo a la lista. 

Cómo borrar toda la lista de Autocompletar

En esta sección se explica cómo eliminar la lista de Autocompletar.
Outlook 2010, Outlook 2013 y Outlook 2016

Use uno de los dos métodos siguientes para eliminar la lista de Autocompletar en Outlook 2010, Outlook 2013 y Outlook 2016.

Método 1

  1. Abra Outlook.
  2. En la pestaña Archivo, haga clic en Opciones.
  3. Haga clic en la pestaña Correo.
  4. En Enviar mensajes, haga clic en Vaciar lista de Autocompletar.

    Ventana Opciones de Outlook
  5. Haga clic en .

Método 2

Inicie Outlook con el modificador /CleanAutoCompleteCache. Para ello, siga estos pasos:
  1. Haga clic en Inicio y, luego, en Ejecutar.
  2. Escriba Outlook.exe /CleanAutoCompleteCache.

    Nota: Si Outlook no está instalado en la ubicación predeterminada, deberá indicar la ruta de Outlook.exe.
Outlook 2003 y Outlook 2007
Para eliminar la lista de Autocompletar de Outlook 2003 y Outlook 2007, tiene que eliminar el archivo .nk2 manualmente. Para eliminar el archivo .nk2, siga estos pasos:
  1. Cierre Outlook.
  2. Haga clic en Inicio y luego en Equipo.
  3. Haga clic en Organizar y luego en Opciones de carpeta y búsqueda.
  4. En la pestaña Ver, haga clic en Mostrar archivos, carpetas y unidades ocultos.
  5. Haga clic en Aceptar.
  6. Haga clic en Inicio, Todos los programas, Accesorios y, por último, en Ejecutar.
  7. En el cuadro de diálogo Ejecutar, escriba el comando siguiente (incluyendo las comillas) y luego haga clic en Aceptar:

    “C:\ Users\NombreDeUsuario\AppData\Roaming\Microsoft\Outlook”


    Nota: NombreDeUsuario en esta ruta es el nombre del usuario con la sesión iniciada actualmente en Windows.
  8. Haga clic con el botón derecho en el archivo .nk2 que tenga el nombre del perfil que quiere restablecer y luego haga clic en Cambiar nombre
  9. Cambie el nombre del archivo por profilename.bak y luego presione Entrar.
  10. Inicie Outlook.
 

Problemas con la caché de Autocompletar

En esta sección se describen algunos problemas conocidos que pueden surgir con la caché de Autocompletar. Es posible que la caché de Autocompletar se dañe con el paso del tiempo y no guarde entradas nuevas. Si esto ocurre, puede intentar quitar entradas de la lista individualmente. Para hacerlo, consulte la sección "Cómo quitar entradas de la lista de Autocompletar individualmente". Si eso no resuelve el problema, puede restablecerse toda la lista de Autocompletar. Para hacerlo, consulte la sección "Cómo borrar toda la lista de Autocompletar".
 

Cómo cambiar el límite de la lista de Autocompletar

Dado que esta configuración no está probada, no se recomienda. Si tiene una lista de Autocompletar grande, también podría perder un gran número de entradas almacenadas si la caché de Autocompletar se daña y no puede usarse. Dada esta declinación de responsabilidades, puede usar los datos del Registro siguientes para aumentar el límite de la lista de Autocompletar en Outlook.

Importante: En esta sección, método o tarea se incluyen pasos para modificar el Registro. Sin embargo, se pueden producir problemas graves si modifica el Registro incorrectamente. Por tanto, asegúrese de que sigue estos pasos cuidadosamente. Para mayor protección, realice una copia de seguridad del Registro antes de modificarlo. De esta manera podrá restaurar el Registro en caso de que se produzca un problema. Para obtener más información acerca de cómo realizar una copia de seguridad y restaurar el Registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
 
322756 Hacer una copia de seguridad del Registro y restaurarlo en Windows
  1. Cierre Outlook.
  2. Inicie el Editor del Registro.
     
    • En Windows 8.x, presione la tecla de Windows, escriba regedit y, luego, presione Entrar.
    • En Windows 7 y Windows Vista, haga clic en Inicio, escriba regedit en el cuadro Iniciar búsqueda y, a continuación, presione Entrar.
  3. Busque la siguiente subclave del Registro y selecciónela:
     
    HKEY_CURRENT_USER\Software\Microsoft\Office\x.0\Outlook\AutoNameCheck

    Nota El marcador de posición x.0 en esta subclave del Registro representa la versión de Microsoft Office. Use el valor adecuado de la lista siguiente.

    Outlook 2016: 16.0
    Outlook 2013: 15.0
    Outlook 2010: 14.0
    Outlook 2007: 12.0
    Outlook 2003: 11.0
  4. En el menú Edición, seleccione Nuevo y haga clic en Valor DWORD.
  5. Escriba MaxNickNames y presione Entrar.
  6. En el menú Edición, haga clic en Modificar.
  7. Escriba el valor nuevo del límite y, luego, haga clic en Aceptar.

    Notas
    • Asegúrese de escribir el número en formato decimal. Esa es la manera correcta de escribir el número.
    • Intente aumentar el límite solo una pequeña cantidad para probar el límite nuevo. Por ejemplo, para aumentar en un 20 por ciento el límite en Outlook 2013, debería especificar 1200 para el valor MaxNickNames.
  8. Salga del Editor del Registro.
  9. Inicie Outlook.
Nota: El valor del Registro MaxNickNames especifica, simplemente, el límite no predeterminado. Por tanto, también puede usar este valor para disminuir el límite de la caché de alias.