SharePoint Workspace returns error "Harmonica version not found"

Symptoms

Consider the following scenario:
  • You use a Microsoft SharePoint document library that has a nested folder structure that resembles the following:

    Library

    Folder1

    Subfolder1
    Subfolder2
    Subfolder3
  • You sync the site that contains this library to a SharePoint workspace.
In this scenario, the library syncs correctly at first. But later, the following sequence of events occurs:
  1. While offline, you use the workspace to edit a file in one of the subfolders.
  2. You come online.
  3. The upload of the edited file fails, and the workspace displays the Error Tools Resolve tab.
  4. In Error Tools Resolve, you click Resolve Conflict or Error.
  5. The Microsoft Office Upload Center appears.
  6. The Upload Center displays the error "Upload failed. Server file updated."
  7. You know that you are the only person who should be editing this file. Therefore, you click Resolve, click Choose, and then click Keep My Version.
The Keep My Version option should replace the server version of the file with the workspace version. However, you end up in the following state instead:
  • The Upload Center reports "Upload Pending."
  • The server shows the earlier version of your edited file. However, the earlier version appears in the root of the library, not in the subfolder. Your changes never upload. 
  • The workspace shows both the current and earlier versions of your file in the root of the library, and your subfolder is gone. If you click Resolve Error on the Error Tools Resolve tab, you may receive the following notification briefly:
    Errors were encountered while synchronizing….
    When you click More Info, you receive the following error message:
    Harmonica version not found.
Note On an installation of Microsoft Office that does not have current updates, you may also see this issue when the file is only one level down from the root of the library.

Cause

This error occurs when the folder structure in the document library is deleted and then re-created. Because the functions that sync content identify folders by ID, not by name, SharePoint Workspace and the Upload Center know that the edited file cannot be returned to its original location. In this case, they will try to match by name. However, this mapping does not work if two or more levels of folders were deleted and then replaced.

Resolution

To restore synchronization, you must disconnect the library from the workspace and then reconnect the library to the workspace. To do this, follow these steps: 
  1. In the workspace, select the affected document library.
  2. Click the Sync tab, click Change Sync Settings, and then click Disconnect <library name> from Server.
  3. Under Available on Server, select the document library, and then click Connect <library name> to Server.
Note All library data must be fetched again when you reconnect the library.

More Information

On the SharePoint server, try to avoid deleting and re-creating folders that contain content. If you have to delete and re-create folders in a document library, advise users who synchronize the affected library to a workspace to disconnect the library before you delete and replace content. This makes the transition smoother. 

If you frequently have nested folders in SharePoint document libraries, you may want to consider other ways to organize your content, such as custom views or more exactly defined sites.
Propiedades

Id. de artículo: 2754412 - Última revisión: 7 sept. 2012 - Revisión: 1

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