Lync mobile client for Windows phone cannot receive push notification

Symptoms

The Lync mobile client for Windows phone cannot receive a push notification for an instant message. 


Usingthe Lync 2010 mobile client

To troubleshoot the issue, use the Lync Server Logging Tool with Lync Server 2010 Front-end server(s) or with Lync Server 2013 Front-end server(s) to gather Mcx logging.

Note Use the following link to download and install the OcsLogger.exe utility for Lync Server 2013 to take Mcx logging from specific Lync Server 2013 Front End servers

Using the Centralized Logging Service

Use the following steps to launch the Lync Server Logging Tool from the Windows Server console:

Using Windows Server 2012
  1. For Lync Server 2013 press the Windows function key and choose the Search option
  2. Type in Explore.exe and click on the Search icon
  3. Use Windows Explorer to browse to <local drive:>\Program Files\Microsoft Lync Server 2013\Debugging Tools, use the Windows Explorer details pane to locate OcsLogger.exe and double click on it
  4. For Lync Server 2010 press the Windows function key to access the Start page
  5. Click on the Lync Server Logging Tool tile
Using Windows Server 2008 or Windows Server 2008 R2

  1. Click on Start, All Programs, Microsoft Lync Server and then choose Lync Server Logging Tool
Use the following steps to continue with taking the Mcx logging:

  1. Select the Mcx logging component from the Logging Options selection
  2. Check the All Levels, and then check All Flags
  3. Click on the Start Logging button
  4. Sign out of and then sign back into the Lync 2010 mobile client from the Windows phone device
  5. Click on the Lync Server Logging Tool's Stop Logging button
  6. Click on the Lync Server Logging Tool's View Log Files button to open the Mcx log in a text format

In the Lync Server Mcx logs search for the following information: 

<enableMicrosoftPushNotification>false</enableMicrosoftPushNotification>


Use the following TechNet article to enable logging for the Lync 2010 mobile client:

Technical Considerations for Mobile Clients


Usingthe Lync 2013 mobile client


To troubleshoot the issue further, use the Lync Server Logging Tool on the Lync Server 2013 Front-end server(s) to gather UCWA logging:

Note Use the following link to download and install the OcsLogger.exe utility for Lync Server 2013 to take UCWA logging from specific Lync Server 2013 Front End servers

Microsoft Lync Server 2013 Debugging Tools

Use the following steps to launch the Lync Server Logging Tool from the Windows Server console:

Using Windows Server 2012

  1. Press the Windows function key and choose the Search option
  2. Type in Explore.exe and click on the Search icon
  3. Use Windows Explorer to browse to <local drive:>\Program Files\Microsoft Lync Server 2013\Debugging Tools, use the Windows Explorer details pane to locate OcsLogger.exe and double click on it
Using Windows Server 2008 or Windows Server 2008 R2

  1. Click on Start, All Programs, Microsoft Lync Server and then choose Lync Server Logging Tool
Use the following steps to continue with taking the UCWA logging:
  1. Select the UCWA logging component from the Logging Options selection
  2. Check the All Levels, and then check All Flags
  3. Click on the Start Logging button
  4. Sign out of and then sign back into the Lync 2013 mobile client from the Windows phone device
  5. Click on the Lync Server Logging Tool's Stop Logging button
  6. Click on the Lync Server Logging Tool's View Log Files button to open the Mcx log in a text format

In the Lync mobile client logs from the Windows phone device search for the following information:

Push notifications inband setting is False 


Cause

The Lync Server  configuration for EnableMicrosoftPushNotificationService is set to False:

Resolution

To verify that the Lync Server configuration for EnableMicrosoftPushNotificationService is set to False. From the Lync Server Front-end server:

  1. Launch the Lync Server Management Shell from the Windows Server console
  2. Use the Get-CsPushNotificationConfiguration cmdlet
Use the following steps the Lync Server Front-end server to enable push notifications for the Lync mobile client on the Windows phone device:

  1. Launch the Lync Server Management Shell from the Windows Server console
  2. Use the Set-CsPushNotificationConfiguration cmdlet as shown in the example listed below:

    Set-CsPushNotificationConfiguration – EnableMicrosoftPushNotificationService $True
  3. To ensure that the configuration changes are available to all servers in the Lync Server Front-end pool use the following command:

    Invoke-CsManagementStoreReplication

Note There could be a two to three minute delay as changes are processed by the Master Replicator. Once the replication has been completed sign-out and sign back in Lync mobile client for Windows phone.

More Information

Get-CsPushNotificationConfiguration

Set-CsPushNotificationConfiguration

Lync Server 2013 supports the use of the Centralized Logging Service. For detailed information on how to configure the Centralized Logging Service for Instant Messaging (IM) and Presence.

Using the Centralized Logging Service
Propiedades

Id. de artículo: 2757132 - Última revisión: 7 jul. 2013 - Revisión: 1

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