Comportamiento inesperado de Detección automática cuando se tiene la configuración del Registro en la clave \Autodiscover

Síntomas

Cuando Microsoft Outlook intenta recuperar información de detección automática de un servidor que ejecuta Microsoft Exchange Server, puede experimentar resultados inesperados si usa uno o más de los valores de Registro disponibles que se pueden utilizar para controlar la detección automática.

Causa

Cuando Outlook intenta ponerse en contacto con el servicio Detección automática en el servidor de Exchange con el rol de servidor Acceso de clientes (CAS), puede emplear varios métodos diferentes para llegar al servicio, según la topología cliente-servidor. Los métodos implementados actualmente que usa Outlook son los siguientes:

  • Búsqueda de SCP
  • Consulta de dominio raíz HTTPS
  • Consulta de dominio de detección automática de HTTPS
  • Archivo XML local
  • Método de redirección HTTP
  • Consulta de registros SRV
  • Dirección URL almacenada en caché en el perfil de Outlook (nuevo para Outlook 2010 versión 14.0.7140.5001 y versiones posteriores)
  • Conexión directa a Microsoft 365 (nuevo para Outlook 2016 versión 16.0.6741.2017 y posteriores)

De forma predeterminada, Outlook intentará uno o varios de estos métodos si no puede conectar con la detección automática. Por ejemplo, en un escenario con una máquina no unida a un dominio, Outlook intentará conectarse a las direcciones URL predefinidas (por ejemplo, https://autodiscover.contoso.com/autodiscover/autodiscover.xml) mediante DNS. Si falla, Outlook probará el método de redirección HTTP. Si también falla, Outlook intentará utilizar el método de búsqueda de registros SRV. Si ninguno de los métodos de búsqueda funciona, Outlook no podrá obtener la configuración ni los ajustes de URL de Outlook en cualquier lugar.

Para obtener más información sobre los diferentes métodos de conexión de detección automática que utiliza Outlook, consulte los siguientes documentos del servicio de detección automática de Exchange:

En algunos escenarios, sin embargo, es posible que desee utilizar valores de Registro o directiva relacionados con la detección automática para controlar los métodos que Outlook usa para llegar a la detección automática. Sin embargo, si configura los valores de Registro o directiva de detección automática incorrectamente, puede impedir que Outlook obtenga información de detección automática.

Solución

Para resolver este problema, revise los datos del Registro relacionados con la detección automática que pueda tener en su cliente de Outlook para asegurarse de que se hayan configurado correctamente. Además, si no está seguro de si se necesitan los datos del Registro, considere la posibilidad de cambiar los datos de cualquiera de estos valores del Registro a cero (0) y luego pruebe Outlook para ver si experimenta alguna diferencia en la detección automática.

Importante

Esta sección, método o tarea contiene pasos que le indican cómo modificar el Registro. No obstante, pueden producirse problemas graves si modifica el registro de manera incorrecta. En consecuencia, asegúrese de seguir estos pasos cuidadosamente. Para mayor protección, cree una copia de seguridad del registro antes de modificarlo. Después, puede restaurar el registro si se produce un problema. Para obtener más información sobre cómo realizar una copia de seguridad y restaurar el Registro, vaya al artículo siguiente en Microsoft Knowledge Base: 322756 Cómo realizar una copia de seguridad y restaurar el Registro en Windows

  1. Inicie el Editor del Registro.

  2. Busque la siguiente subclave del Registro y selecciónela:

    HKEY_CURRENT_USER\Software\Microsoft\Office\x.0\Outlook\AutoDiscover

    Nota:

    x.0 en esta ruta de acceso del Registro corresponde a la versión de Outlook (16.0 = Outlook 2016, 15.0 = Outlook 2013, 14.0 = Outlook 2010, 12.0 = Outlook 2007).

  3. Revise los siguientes valores DWORD posibles que puedan encontrarse en la subclave \Autodiscover.

    • PreferLocalXML

    • PreferProvidedEmailInAutoDiscoverAuthPrompts

      Este valor permite a los administradores de Exchange especificar si los usuarios se autenticarán mediante el correo electrónico de la cuenta configurada o el nombre principal del usuario (UPN) en situaciones en que se use la detección automática. Para más información, consulte Actualización del 5 de noviembre de 2019 para Outlook 2016 (KB4484139).

    • ExcludeHttpRedirect

    • ExcludeHttpsAutoDiscoverDomain

    • ExcludeHttpsRootDomain

    • ExcludeScpLookup

    • ExcludeSrvRecord

    • ExcludeLastKnownGoodURL (solo se aplica a Outlook 2010 versión 14.0.7140.5001 y versiones posteriores)

    • ExcludeExplicitO365Endpoint (solo se aplica a Outlook 2016 versión 16.0.6741.2017 y versiones posteriores)

    Nota:

    Algunos documentos indican que Outlook usa el valor ExcludeSrvLookup en este escenario. Desafortunadamente, esta documentación es incorrecta, ya que el valor ExcludeSrvLookup no existe en el código de Outlook. Outlook solo usa el valor ExcludeSrvRecordregistry para controlar la búsqueda de registros SRV de la detección automática. Por lo tanto, si encuentra un valor denominado ExcludeSrvLookup en la subclave \Autodiscover, puede cambiar su valor a 0 sin problemas.

  4. Repita el paso 3 utilizando la siguiente subclave del Registro:

    HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\x.0\Outlook\AutoDiscover

    Nota:

    x.0 en esta ruta de acceso del Registro corresponde a la versión de Outlook (16.0 = Outlook 2016, 15.0 = Outlook 2013, 14.0 = Outlook 2010, 12.0 = Outlook 2007).

Más información

Puede usar los siguientes pasos en Outlook para determinar el método por el cual Outlook está intentando recuperar información de detección automática de Exchange:

  1. Inicie Outlook.
  2. Mantenga presionada la tecla CTRL, haga clic con el botón derecho en el icono de Outlook que se encuentra en el área de notificación y después haga clic en Probar configuración automática del correo electrónico.
  3. Compruebe que la dirección de correo electrónico se ha especificado correctamente en el cuadro Dirección de correo electrónico.
  4. Escriba su contraseña si no ha iniciado sesión en un dominio o si está accediendo a un buzón de correo que es diferente de su buzón de correo.
  5. Haga clic para desactivar las casillas Usar Guessmart y Autenticación Guessmart segura.
  6. Haga clic en Probar.
  7. Revise los detalles en la pestaña Registro.

La siguiente imagen muestra la pestaña Registro cuando los valores ExcludeScpLookup y ExcludeHttpsAutoDiscoverDomain se han configurado en 1.

La captura de pantalla muestra información en la pestaña Registro cuando los valores ExcludeScpLookup y ExcludeHttpsAutoDiscoverDomain se han configurado en 1.

Compare esta información solamente cuando el valor ExcludeScpLookup esté establecido en 1.

La captura de pantalla muestra información en la pestaña Registro cuando el valor ExcludeScpLookup se establece en 1.

Nota:

Ignore los errores en estas imágenes, ya que esta información solamente tiene como objetivo mostrarle los diferentes intentos de búsqueda realizados por Outlook.

Además, si habilita el registro en Outlook (2007 o 2010), los diferentes intentos de búsqueda de detección automática se podrán encontrar en el archivo %temp%-Olkdisc.log. Este archivo de registro también incluye cualquier configuración del Registro que haya configurado para excluir cualquiera de los métodos de búsqueda de detección automática. En la imagen siguiente, puede ver claramente que los valores ExcludeScpLookup y ExcludeHttpsAutoDiscoverDomain están establecidos en 1.

La captura de pantalla muestra el archivo de registro en el que están activados ExcludeScpLookup y ExcludeHttpsAutoDiscoverDomain.

Para obtener más información sobre la gestión y administración del lado del cliente de detección automática, vaya al siguiente artículo de Knowledge Base:

2612922 Cómo controlar la detección automática de Outlook mediante la directiva de grupo