Puede recibir un error "se produjo un problema al comunicarse con el servidor OLE Microsoft Access" mensaje incrustar o vincular un documento de Word en Access


Importante: este artículo contiene información que muestra cómo reducir la configuración de seguridad o desactivar las características de seguridad en un equipo. Puede realizar estos cambios para solucionar un problema específico. Antes de realizar estos cambios, le recomendamos que evalúe los riesgos asociados con la implementación de esta solución en su entorno concreto. Si decide implementar esta solución alternativa, tome las medidas adicionales oportunas para ayudar a proteger su sistema.
Principiante: Se requieren conocimientos de la interfaz de usuario en equipos de usuario único.


En este artículo se aplica a un archivo de base de datos (.mdb) de Microsoft Access o a un archivo de base de datos (.accdb) de Microsoft Access.

Síntomas


Cuando intenta vincular o incrustar un documento de Microsoft Word en Microsoft Access, puede recibir un mensaje de error similar al siguiente mensaje de error:
Ocurrió un problema al comunicarse con el servidor OLE Microsoft Access. Pruebe una o varias de las acciones siguientes:
  1. Asegúrese de que está conectado al servidor de red donde se encuentra la aplicación de servidor OLE.
  2. Cierre el servidor OLE y reinícielo desde fuera de Microsoft Access.
  3. Vuelva a instalar el servidor OLE para asegurarse de que está registrado.
Nota para los usuarios que ejecutan Microsoft Office Access 2007
Para determinar el número único asociado al mensaje que recibe, presione CTRL + MAYÚS + I. El número siguiente aparecerá en la esquina inferior derecha de este mensaje:
1200553

Causa


Este problema puede producirse si tiene Norton AntiVirus 2000, Norton AntiVirus 2001, Norton AntiVirus 2002, Norton AntiVirus 2003 o Norton AntiVirus 2004 instalado en el equipo. Este problema también puede producirse si se ha ejecutado LiveUpdate de Norton y ha instalado la actualización de Script Blocking de Norton AntiVirus 2004, Norton AntiVirus 2002, Norton AntiVirus 2003 o Norton AntiVirus 2001.

Solución


Importante estos pasos pueden aumentar su riesgo de seguridad. Estos pasos también pueden hacer que su equipo o su red sean más vulnerables a los ataques de usuarios malintencionados o de software malintencionado, como virus. Recomendamos el proceso que se describe en este artículo para permitir que los programas funcionen como están diseñados o para implementar determinadas funciones del programa. Antes de realizarlos, recomendamos que evalúe los riesgos asociados con la implementación de este proceso en su entorno particular. Si decide implementar este proceso, tome las medidas adicionales oportunas para ayudar a proteger su sistema. Recomendamos que utilice este proceso sólo si realmente lo necesita este proceso. Para obtener información adicional acerca de los virus informáticos, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

129972 virus: descripción, prevención y recuperación

Para resolver este problema, utilice uno de los métodos siguientes.

Método 1

Desactivar el bloqueo de secuencias de comandos de Norton AntiVirus

Advertencia: Esta solución puede hacer que su equipo o su red sean más vulnerables a los ataques de usuarios malintencionados o de software malintencionado, como virus. No recomendamos esta solución, pero proporcionamos esta información para que puede implementar esta solución temporal a su propia discreción. Utilice esta solución bajo su propia responsabilidad.

Nota: Un programa antivirus está diseñado para ayudar a proteger el equipo frente a virus. No debe descargar o abrir archivos desde orígenes que no confía, visitar sitios Web que no confía o abrir datos adjuntos de correo electrónico cuando el programa antivirus está deshabilitado.

Nota: Norton AntiVirus 2000 no admite la función de bloqueo de secuencia de comandos. Si utiliza Norton AntiVirus 2000, vea el método 2.

Para Norton AntiVirus 2001, Norton AntiVirus 2002, Norton AntiVirus 2003 o Norton AntiVirus 2004, siga estos pasos:
  1. Inicie Norton AntiVirus.
  2. Haga clic en Opciones.
  3. Si aparece un menú al hacer clic en Opciones, haga clic en Norton AntiVirus .

    Aparecerá el cuadro de diálogo Opciones de Norton AntiVirus .
  4. Haga clic en el bloqueo de Script.
  5. Haga clic para desactivar la casilla de verificación Enable Script Blocking (recomendado) .
  6. Haga clic en Aceptar.
Nota: Puede activar el bloqueo de Script nuevo cuando haya terminado de utilizar Access.

Para obtener información adicional, consulte la documentación del producto Norton, o visite el siguiente sitio Web de Symantec:Si este vínculo no funciona, visite Knowledge Base para Symantec en el siguiente sitio Web de Symantec y, a continuación, busque el documento ID 2001041119095106:

Método 2

Desactivar Norton AntiVirus de Office Plug-in para Microsoft Office

Advertencia: Esta solución puede hacer que su equipo o su red sean más vulnerables a los ataques de usuarios malintencionados o de software malintencionado, como virus. No recomendamos esta solución, pero proporcionamos esta información para que puede implementar esta solución temporal a su propia discreción. Utilice esta solución bajo su propia responsabilidad.

Nota un programa antivirus está diseñado para ayudar a proteger el equipo frente a virus. No debe descargar o abrir archivos desde orígenes que no confía, visitar sitios Web que no confía o abrir datos adjuntos de correo electrónico cuando el programa antivirus está deshabilitado.

Nota: Este método desactiva el antivirus de complemento que se instala durante la instalación de Norton AntiVirus. Este complemento explora documentos para infecciones de virus en programas de Office. Cuando este complemento está desactivado, Norton AntiVirus no explora los documentos que están abiertos. Sin embargo, la característica de protección automática de Norton AntiVirus sigue proporciona una mejor protección de continuo al analizar cualquier archivo que ejecutar, descargar, abrir, crear o eliminar. Para obtener información adicional acerca de Norton AntiVirus, consulte la documentación del producto.

Para Norton AntiVirus 2002, Norton AntiVirus 2003 y Norton AntiVirus 2004, siga estos pasos:
  1. Inicie Norton AntiVirus.

    Nota: Si Norton AntiVirus es parte de Norton SystemWorks (NSW) o Norton Internet Security (NIS), iniciar nueva Gales del sur o NIS y, a continuación, haga clic en Norton AntiVirus.
  2. Haga clic en Opcionesy, a continuación, haga clic en varios.
  3. En la sección cómo mantener protegidos los documentos de Microsoft Office , haga clic en el complemento de Office permiten .

    Esto borra el complemento de Office permiten.
  4. Haga clic en Aceptary, a continuación, salga de Norton Antivirus.
Para Norton AntiVirus 2001, siga estos pasos:
  1. Inicie Norton AntiVirus 2001.

    Nota: Si Norton AntiVirus es parte de Norton SystemWorks (NSW) o Norton Internet Security (NIS), iniciar nueva Gales del sur o NIS y, a continuación, haga clic en Norton AntiVirus.
  2. Haga clic en Opcionesy, a continuación, haga clic en General.
  3. En la sección de complemento de Microsoft Office 2000 , haga clic en Habilitar complemento.

    Esto borra la habilitar complemento.
  4. Haga clic en Aceptary, a continuación, salga de Norton Antivirus.
Para Norton AntiVirus 2000, siga estos pasos:
  1. Haga clic en Inicio y, a continuación, haga clic en Ejecutar.
  2. En el cuadro Abrir , escriba uno de los siguientes comandos y, a continuación, presione ENTRAR.

    El comando que escriba depende de su sistema operativo y el software que se ejecuta. Asegúrese de incluir las comillas al escribir los comandos.
    • Para Windows 95 o Windows 98 con Norton AntiVirus instalado, escriba el comando siguiente:
      "C:\Windows\System\Regsvr32" -U "C:\Program Files\Norton AntiVirus\OfficeAV.dll" 
    • Para Windows 95 o Windows 98 con SystemWorks instalado, escriba el comando siguiente:
      "C:\Windows\System\Regsvr32" -U "C:\Program Files\Norton SystemWorks\Norton AntiVirus\OfficeAV.dll" 
    • Para Windows NT o Windows 2000 con Norton AntiVirus instalado, escriba el comando siguiente:
      "C:\Winnt\System32\Regsvr32" -U "C:\Program Files\Navnt\OfficeAV.dll" 
Si el comando es correcto, recibirá el siguiente mensaje:

DllUnregisterServer en C:\Program programa\Norton AntiVirus\OfficeAV. dll se realizó con éxito.


Si el comando no es correcto, busque el disco duro para el archivo OfficeAV.dll. La ruta de acceso del archivo OfficeAV.dll en su equipo puede ser diferente de la ruta de acceso en el mensaje. Cuando encuentre el archivo OfficeAV.dll, recuerde la ubicación del archivo OfficeAV.dll y, a continuación, siga estos pasos de nuevo. Sin embargo, esta vez cambie la parte de "C:\Program de programa\norton antivirus\officeav. dll" del comando en el paso 2 para la ruta de acceso del archivo OfficeAV.dll en su equipo.

Para obtener información adicional, consulte la documentación del producto Norton, o visite el siguiente sitio Web de Symantec:

Si este vínculo no funciona, visite Knowledge Base para Symantec en el siguiente sitio Web de Symantec y busque 1999091612160606 de ID de documento:

Método 3

Reinstale Norton Antivirus

Para todas las versiones de Norton AntiVirus, siga estos pasos:
  1. Quitar Norton AntiVirus y, a continuación, reinicie el equipo.
  2. Inicie Word.
  3. En el menú Ayuda, haga clic en detectar y reparar.
  4. Reinstale Norton AntiVirus y, a continuación, reinicie el equipo.

Más información


Pasos para reproducir el problema

  1. Instalar Norton AntiVirus 2000.
  2. Crear una nueva base de datos de Access 2000.
  3. Cree la siguiente tabla y, a continuación, guarde la tabla como Tabla1:
       Table: Table1
    ----------------------------
    Field Name: ID
    Data Type: AutoNumber
    Indexed: Yes (No Duplicates)

    Field Name: Test
    Data Type: OLE Object

    Table Properties: Table1
    ------------------------
    PrimaryKey: ID

  4. Crear un formulario que se basa la tabla Tabla1. Guardar este formulario como OLETest.
  5. Abra el formulario OLETest en la vista formulario.
  6. Haga clic en el campo prueba y, a continuación, haga clic en Insertar objeto.
  7. En el cuadro de diálogo Insertar objeto , haga clic en crear desde archivo.
  8. Escriba la ruta de acceso de un documento de Word, o haga clic en Examinar para seleccionar un documento de Word.
  9. En el cuadro de diálogo Insertar objeto , haga clic en Aceptar para cerrar el cuadro de diálogo.

    Recibirá uno de los mensajes de error que se menciona en la sección "Síntomas".

Referencias


Para obtener información adicional acerca del complemento Norton AntiVirus de Office, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

329820 cómo utilizar programas de Office con el complemento Norton AntiVirus de Office

Microsoft proporciona información de contacto de terceros para ayudarle a encontrar soporte técnico. Esta información de contacto puede cambiar sin previo aviso. Microsoft no garantiza la exactitud de esta información de contacto de terceros.
Para obtener más información acerca de proveedores de hardware y software, información de contacto, visite el siguiente sitio Web de Microsoft:

Los productos de terceros que se indican en este artículo están fabricados por compañías independientes de Microsoft. Microsoft no otorga ninguna garantía, implícita o de otro tipo, respecto al rendimiento o la confiabilidad de estos productos.